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SPECIFIC LEARNING OUTCOMES 

By the end of this unit you should; 

 Understand databases and know how to manage data using database 

software, e.g. Microsoft Access  

 Be able to use Microsoft Access 

 Construct multi-relation database 

 Be able to query, sort and summarize data 

 Perform database housekeeping activities (editing and updating) 

 Create user interface menus 

Key inquiry questions 

1. What is a database and database management system? 

2. What is Microsoft Access? 

3. What is the importance of databases? 

4. How are data tables created in Microsoft Access? 

5. How are data relations joined in a database? 

6. How is data queried, sorted and summarized to generate reports? 

7. How are books managed in a school library? (a small library information 

system)  



 

 

A database can be defined as a collection of data, or information that is specially 

organized for rapid search and retrieval by a computer. It is a collection of 

information that is organized so that it can be easily accessed, managed and 

updated. Databases are structured to facilitate the storage, retrieval, modification, 

and deletion of data in conjunction with various data-processing operations. 

 

Work in pairs 

A family has four children and a lot of paperwork relating to their education 

(e.g. school books, test papers, school fees, certificates) and their health (e.g. 

medical records, vaccinations). 

They have bought a filing cabinet with four drawers. Suggest how they should 

use the filing cabinet so that they can easily find every document. 

Write your explanations and discuss with your partner. Be prepared to answer 

questions about your explanation. Which pair has the most convincing 

explanation? 

A database is an electronic version of the paper filing system you were been 

planning in activity 1. Obviously an electronic database has many advantages over 

a paper-based system. 

Data is organized into rows, columns and within tables. Databases process 

workloads to create and update themselves, querying the data they contain and 

running applications against it. 

Computer databases typically contain a compilation of data records or files, such as 

sales transactions, product catalogs and inventories, and customer profiles.  

Uses for database systems include: 

 Data storage. They also store special information used to manage the data. 

This information is called metadata and it is not shown to all the people 

looking at the data. 

 Access Control. They can solve cases where many users want to access (and 

possibly change) the same entries of data. They manage access rights (who 

is allowed to see the data, who can change it)  



 

 

 Concurrent users. When there are many users asking questions to the 

database, the questions must be answered faster. So, the last person to ask 

a question can get an answer in reasonable time. 

 Certain attributes are more important than others; they can be used to find 

other data. This is called indexing. An index contains all the important data 

and can be used to find the other data. 

 They ensure that the data always has context. There are a lot of different 

rules that can be added to tell the database system if the data makes sense. 

One of the rules might say November has 30 days. This means if someone 

wants to enter November 31 as a date, this change will be rejected. 

 

Work in pairs 

1. Why is file naming important? 

2. How should you name your file? 

3. How should files be structured? 

Discuss 

Write your explanations and discuss with your partner. Be prepared to explain 

your answer. 

Work together with your partner to develop a presentation that explains in 

detail about file naming and structure and their importance. Relate this to 

everyday usage of data in computers. 

Presentation 

Make your presentation to the class. 

 

 

 

 

 



 

 

 

A database management system (DBMS) is system software for creating and 

managing databases. The DBMS provides users and programmers with a systematic 

way to create, retrieve, update and manage data. 

A database schema is the skeleton structure that represents the logical view of the 

entire database. It defines how the data is organized and how the relations among 

them are associated. It formulates all the constraints that are to be applied on the 

data. 

The DBMS is most useful for allowing access to data by multiple users, from 

multiple locations. A DBMS can limit what data the end user sees, as well as how 

that end user can view the data. 

 Improved data sharing. 

 Integrity can be enforced. 

 Minimized data inconsistency. 

 Providing backup and recovery 

 Improved data security. 

Database management systems are important to businesses and organizations 

because they provide a highly efficient method for handling multiple types of data. 

Some of the data that are easily managed with this type of system include:  

 Employee records 

 Learners information 

 Payroll, accounting 

 Project management 

 Inventory and library books.  

These systems are built to be extremely versatile. 

Without database management, tasks have to be done manually and take more 

time. Data can be categorized and structured to suit the needs of the company or 

organization. Data is entered into the system and accessed on a routine basis by 

assigned users. Each user may have an assigned password to gain access to their 

part of the system. Multiple users can use the system at the same time in different 

ways. 



 

 

For example, a company's human resources department uses the database to 

manage employee records, distribute legal information to employees and create 

updated hiring reports. A manufacturer might use this type of system to keep track 

of production, inventory and distribution. In both scenarios, the database 

management system operates to create a smoother and more organized working 

environment. 

 

Work in groups  

In what ways do you think an electronic database is better than a paper-based system? 

Compare processes involved in each. 

Presentation 

Develop presentations of answers in each question and present to the whole 

class. What are the common answers in each group? 

 

 

1. Relational database management system (RDMS) – This is based on the 

relational model; most databases in widespread use are based on the 

relational database model.  

2. NoSQL DBMS ("not only SQL,”) – this is an approach to database design that 

can accommodate a wide variety of data models, including key-value, 

document, columnar and graph formats.  

3. In-memory database management system (IMDBMS) - this is a database 

management system that primarily relies on main memory for computer 

data storage. It is contrasted with database management systems that 

employ a disk storage mechanism.  

4. Columnar database management system (CDBMS) – this is a database 

management system (DBMS) that stores data tables by column rather than 

by row. In a relational database, data access is always by row. Changing the 

focus from the row to column can improve performance when large 

amounts of data are aggregated in a few columns.  

5. Cloud-based data management system - is a database that typically runs on 

a cloud computing platform, access to it is provided as a service the cloud 

http://searchdatamanagement.techtarget.com/definition/NoSQL-DBMS-Not-only-SQL-database-management-system
http://searchcloudprovider.techtarget.com/definition/cloud-services


 

 

service provider is responsible for providing and maintaining the DBMS. 

Compared with operating a traditional database on an on-site physical 

server and storage architecture, a cloud database offers the following 

distinct advantages:  

 Elimination of physical infrastructure.  

 Cost savings.  

Exercise 1 

1. List the features of each popular type of databases. 

2. What are the uses of popular types of databases? 

Computer programs, particularly those which manipulate data, are built using 

structures and manipulations to organize data with one of the goals being to 

present to a final user data in an organized and comprehensible form.  

Data stored in computer systems form a hierarchy extending from a single bit to a 

database, the major record-keeping entity of a firm. Each higher rung of this 

hierarchy is organized from the components below it. 

Bits and Bytes A bit is the smallest unit of data representation (value of a bit 
may be a 0 or 1). Eight bits make a byte which can represent 
a character or a special symbol in a character code. 

Fields (rows) A field consists of a grouping of characters. A data field 
represents an attribute (a characteristic or quality) of some 
entity (object, person, place, or event). 
 

Records (rows) A record represents a collection of attributes that describe a 
real-world entity. A record consists of fields, with each field 
describing an attribute of the entity. 

Files This is a group of related records. Files are frequently 
classified by the application for which they are primarily used 
(employee file) e.g. employee files, safety records, Test 
scores. 

Databases This is an integrated collection of logically related records or 
files. A database consolidates is managed by systems 
software called database management systems (DBMS).  
 

 

http://searchcloudprovider.techtarget.com/definition/cloud-services


 

 

 

Microsoft Access is a database management system (DBMS) from Microsoft that is 

an information management tool that helps you store information for reference, 

reporting, and analysis.  

Microsoft Access helps you analyze large amounts of information, and manage 

related data more efficiently than Microsoft Excel or other spreadsheet 

applications. 

 

 

 

 

 

 

 

 

 

 

Fig 1.1 MS Access 2016 Welcome Screen 

A spreadsheet program is a terrific tool for maintaining and calculating small sets of 

information.  Microsoft Excel is easy to understand, create column names, enter 

your data, and create formulas.   

You can sort, filter, and format the data quickly and easily.  But spreadsheets are 

not ideal for handling hundreds of records where you need to have "one version of 

the truth" for something like a customer, a contact, or main "thing" you need to 

track.   

It is very easy to introduce errors into a spreadsheet, which then makes analysis, 

summing, and reporting very challenging.  The image below provides a quick 

example of several key challenges spreadsheets face. 



 

 

 

Microsoft Access is equipped with all the tools you will need to start a project, to 

end it, and to distribute it. As is the case for every application, to use Microsoft 

Access, you must launch it, which is done from the menu on the Start button of 

Microsoft Windows. When it starts, Microsoft Access displays two sections: 

 

Figure 1.2 Microsoft access sections 

The left side displays a list of previously used files. The right side displays a list of 

example databases. To start with a project from scratch, you can click Blank 

Desktop Database. This would bring up a dialog box: 

 

 

 

 

 

 

 

In the dialog box, specify the desired name of the file and click Create. 

To Create a Database; 

1. In the middle section, click Blank Desktop Database. 

Figure 1.3 a dialog box 

http://www.functionx.com/access/windows/startup1.png
http://www.functionx.com/access/windows/startup2.png


 

 

2. In the right section of the screen, set the File Name to database. 

3. Click Create. 

Work in pairs 

Open Microsoft Access 

Create a data table with a few columns and insert some simple data. 

Try using each of the tools to manipulate the data to familiarise yourself with the tools. 

Discuss the value of each tool with your class. 

  

The primary language to perform the operations on a database is called the 

structured query language, or SQL. As it is common with other computer 

languages, the SQL has its own syntax, vocabulary, and rules. The SQL language is 

equipped with key words that tell it what to do and how to do it. Microsoft Access 

supports many ways of using, interpreting, or applying the SQL language. 

Code based on SQL is referred to as a SQL statement. In Microsoft Access, to open 

a window you can use to create or use a SQL statement, on the Ribbon, click 

Create. In the Queries section, click Query Design. This would display the Show 

Table dialog box. Click Close. 

To open the window that allows you to write code: 

 Right-click the middle of the Query window and click SQL View 

 On the Ribbon, in the Results section of the Design tab of the Ribbon, click 

the SQL button  

 On the Ribbon, in the Results section, click the arrow of the View button 

and click SQL View 

 On the status bar of the Query window, click the SQL View button  

This would display a window with a default line of code. This is referred to as the 

Query window. In it, you can either edit its existing code or delete the default code 

and replace it with your own code. 



 

 

When writing a SQL statement, the SQL is not case-sensitive. This means that the 

words Case, case, and CASE represent the same thing. This applies to keywords of 

the SQL or words that you will add in your statements. 

After writing your SQL statement, you can execute it to see the result. To do this: 

 In the Results section of the Ribbon, click the Run button  

 In the Results section of the Ribbon, click the View button  

 In the status bar of Microsoft Access, click the Datasheet View button  

After viewing the result, to return to the Query window: 

 Right-click the title bar of the window and click SQL Code 

 In the Results section of the Home tab of the Ribbon, click the arrow of the 
View button and click SQL Code. 

 

As you work through the following section it would be useful to try out the 

processes described so that you gain experience of using the database. 

The most fundamental operator used in the SQL is called SELECT. This operator is 
primarily used to display a value to the user. In this simple case, it uses the 
following formula: 

SELECT Value; 

The value on the right side of SELECT must be appropriate. It can be a number. 

Here is an example: 

SELECT 48; 

When you write a SQL statement, the semicolon is optional. This means that you 

can omit it. 

SELECT This AS 

Practical Example 



 

 

When you execute a SQL statement in the Query window, its results are displayed 
in a spread sheet. To be able to recognize a value, the top section of a column of 
the spread sheet displays a label, called a caption. For example, the above would 
produce: 

 

Figure 1.4 value selection 

If you create a simple SELECT Value; Microsoft Access assigns a default caption to 

the column. The SQL allows you to specify a caption that would be used for the 

value. This is done using the following basic formula: 

SELECT Value as Caption; 

The words, “SELECT” and “AS” are required. As mentioned already, “SELECT” would 

be used to specify a value and “AS” in this case allows you to specify a caption of 

your choice. 

The caption can be made of a word but the word cannot be one of the SQL's 

keywords. Here is an example: 

SELECT 48 AS Age; 

This would produce: 

 

Figure 1.5 24.85 selection 



 

 

You can also use non-literal characters or digits in the caption. If the caption is 

made of a combination of words, you can concatenate them to create one word. 

Here is an example: 

SELECT 24.85 AS Hourly Salary; 

This would produce: 

 

Figure 1.6 48 selection 

If you want the caption to display different words, you can include them between 

an opening square bracket "[" and a closing bracket "]". Here is an example: 

SELECT 25.05 AS [Hourly Salary]; 

This would produce: 

 

Figure 1.7 25.05 selection 

Instead of displaying one column, you may want to display more. To do this, 

separate them with commas. Here is an example: 

SELECT 42.50 AS [Weekly Hours], 25.05 AS [Hourly Salary]; 

This would produce: 



 

 

 

Figure 1.8 42.05 selection 

Besides a number, the value of a SELECT expression can be a string. If it is, you can 

include it between single-quotes. Here is an example: 

SELECT 'Martens, Laurent' AS [Employee Name]; 

In the same way, you can mix number-based and string-based columns. 

The structured query language comes in two broad parts. The data definition 

language (DDL) is the SQL part used to create the objects of a database. 

A form is a rectangular object that hosts other objects and allows a database user, 

also called a user, to interact with the application. There are various ways you can 

create a form. If you want to immediately use the form, on the Ribbon, click Create. 

In the Forms section, click Form View. 

If you want to prepare the form to receive other objects, this is referred to as 

design. To open a form for design, on the Ribbon, click Create. In the Forms section, 

click Form Design. When a form is in design, you can add objects to it. 

 

 

 

As you work through the following section it would be useful to try out the 

processes described so that you gain experience of using the database. 

Practical Example 



 

 

The Form View is the view used for regular operations on a form. To open a form in 

Form View: 

In the navigation panel:  

 Double-click the name of the form 

 Right-click the form and click Open 

If the form is opened in another type of view:  

 In the navigation Pane, double-click the name of the form. 

 On the Ribbon, click Home, Design, or Datasheet (this depends on the type 

of view). In the Views section (on the left of the Ribbon), click the arrow 

button under View, and click Form View. 

 On the status bar, click the Form View button. 

 

 

Figure 1.9 form view button 

The design of a form is done by displaying the object in Design View. To present a 

form in Design View: 

If the form is currently closed, in the Navigation Pane, right-click the form and click 

Design View 

If the form is currently opened: 

 In the Navigation Pane, right-click the form and click Design View 

 Right-click its title bar or tab and click Design View 

 Right-click it (somewhere on its body) and click Design View 

 On the Ribbon, click Home. In the Views section, click the arrow button 

under View and click Design View  



 

 

 

Figure 1.10 design view 

 On the right side of the status bar, click the Design View button  

 

Figure 1.11 design view button 

If the form is currently displaying in Design View and you want to switch it to Form 

View: 

In the Navigation Pane:  

 Double-click the name of the same form 

 Right-click the name of the same form and click Open 

On the Ribbon, click either Design or Home, in the Views section:  

 Click the View button 

 Click the down-pointing button under View and click Form View 

To start a simple report, on the Ribbon, click Create. In the Reports section, click 

Report View. To start a report that will host some objects, which referred to as 

design, on the Ribbon, click Create. In the Reports section, click Report Design. If 

the report is currently closed or it displays in another view, you can switch the view 

using the same techniques applied to a form. 



 

 

The Detail section is the primary host of the controls on a form or report. The 

section is primarily characterized by its height. To visually change the height of the 

Detail section, click and drag the lower border of the Detail section: 

 

Figure 1.12 lower border drags 

A form can be equipped with a Form Header and a Form Footer sections. To add 

these sections, right-click the middle of the form and click Form Header/Footer:  



 

 

 

Figure 1.13 form header/ footer selection 

  

Figure 1.14 report header/ footer selection 

A report can be equipped with a Report Header and a Report Footer section. To 

add these sections, right-click the body of the report and click Report 

Header/Footer: 



 

 

 

 

Figure 1.15 report header and footer selection. 

You can increase the height of a section or reduce the height, sometimes 

completely. This allows you to keep one section and hide the other. 



 

 

The width of a form or that of a report is the distance from its left border to its 

right border. All sections use the same width. To widen or narrow a form or report, 

click and drag the right border: 

 

Figure 1.16 widening and narrowing selection 

The height of a form or report is controlled by its sections. 

To change both the width and the height of a form or report at the same time, 

position the mouse on the lower-right corner: 



 

 

 

Figure 1.17 drag left, right, up, down, or diagonally 

Then click and drag left, right, up, down, or diagonally. 

If you want to resize a form enough to show its whole content, on the Ribbon, click 

Home. In the Window section, click Size to Fit Form. 

There are various ways you can create a database. To visually start a database from 

scratch, after launching Microsoft Access, click Blank Desktop Database. In the right 

section, accept or change the name of the database. 

If you want to create a contemporary database, either omit or add the .accdb 

extension. If you want to create a database that is compatible with earlier versions 

of Microsoft Access, you must add the extension .mdb. 

After specifying the name, to specify a folder of your choice, under File Name and 

on the right side of the name of the database, click the Browse button . This 

would open the File New Database dialog box. You can click the arrow of the Save 

In combo box to select a drive such as (A:), (C:), etc. 



 

 

After selecting the drive, you can either select an existing folder or create a new 

folder by clicking the Create New Folder button on the right side of the Save In 

combo box. You can also use a directory on the network as the repository of the 

new database. 

Access comes with a variety of templates that you can use as-is or as a starting 

point. A template is a ready-to-use database that contains all the tables, queries, 

forms, macros, and reports needed to perform a specific task. For example, there 

are templates that you can use to track issues, manage contacts, or keep a record 

of expenses. Some templates contain a few sample records to help demonstrate 

their use. 

If one of these templates fits your needs, using it is usually the fastest way to get a 

database started. However, if you have data in another program that you want to 

import into Access, you might decide it is better to create a database without using 

a template. Templates have a data structure already defined, and it might require a 

lot of work to adapt your existing data to the template's structure. 

1. If you have a database open, on the File tab, click Close. Backstage view 

displays the new tab. 

2. Several sets of templates are available in the new tab, some of which are 

built into Access. You can download additional templates from Office.com. 

See the next section in this article for details. 

3. Select the template that you want to use. 

4. Access suggests a file name for your database in the File Name box — you 

can change the file name, if you want. To save the database in a different 

folder from the one displayed below the file name box, click , browse to 

the folder in which you want to save it, and then click OK. Optionally, you 

can create and link your database to a SharePoint site. 

 

Note: Although they both use SharePoint, a desktop database linked to a 

SharePoint site is not the same as a web database using Access Services. To 

use a desktop database, you must have Access installed. A web database 

can be used with a web browser. 

5. Click Create. 

Access creates a database from the template that you chose, and then 

opens the database. For many templates, a form is displayed in which you 

can begin entering data. If your template contains sample data, you can 



 

 

delete each record by clicking the record selector (the shaded box or bar 

just to the left of the record), and then doing the following:  

On the Home tab, in the Records group, click Delete.  

6. To begin entering data, click in the first empty cell on the form and begin 

typing. Use the Navigation Pane to browse for other forms or reports that 

you might want to use. Some templates include a navigation form which 

allows you to move between the different database objects. 

 

As you work through the following section it would be useful to try out the 

processes described so that you gain experience of using the database. 

1. On the File tab, click New, and then click Blank Database. 

2. Type a file name in the File Name box. To change the location of the file 

from the default, click Browse for a location to put your database 

(next to the File Name box), browse to the new location, and then click 

OK. 

3. Click Create.  

Access creates the database with an empty table named Table1, and 

then opens Table1 in Datasheet view. The cursor is placed in the first 

empty cell in the Click to Add column. 

4. Begin typing to add data, or you can paste data from another source, as 

described in the section Copy data from another source into an Access 

table. 

Entering data in Datasheet view is designed to be very similar to working in an 

Excel worksheet. The table structure is created while you enter data. When you 

add a new column to the datasheet, a new field is defined in the table. Access 

automatically sets each field's data type, based on the data that you enter. 

If you do not want to enter data in Table1 at this time, click Close . If you made 

any changes to the table, Access prompts you to save the changes. Click yes to save 

your changes, click No to discard them, or click Cancel to leave the table open. 

Practical Example 

https://support.office.com/en-us/article/Create-a-new-database-32a1ea1c-a155-43d6-aa00-f08cd1a8f01e#__toc269904808
https://support.office.com/en-us/article/Create-a-new-database-32a1ea1c-a155-43d6-aa00-f08cd1a8f01e#__toc269904808


 

 

You can add new tables to an existing database by using the commands in the 

Tables group on the Create tab.  

 

Create a table, starting in Datasheet view    In Datasheet view, you can enter data 

immediately and let Access build the table structure behind the scenes. Field 

names are assigned numerically (Field1, Field2, and so on), and Access 

automatically sets each field's data type, based on the data you enter. 

1. On the Create tab, in the Tables group, click Table.  

Access creates the table and selects the first empty cell in the Click to Add 

column. 

2. On the Fields tab, in the Add & Delete group, click the type of field that you 

want to add. If you do not see the type that you want, click More Fields . 

3. Access displays a list of commonly used field types. Click the field type that you 

want, and Access adds the new field to the datasheet at the insertion point. 

You can move the field by dragging it. When you drag a field in a datasheet, a 

vertical insertion bar appears where the field will be placed. 

4. To add data, begin typing in the first empty cell, or paste data from another 

source, as described in the section Copy data from another source into an 

Access table.  

5. To rename a column (field), double-click the column heading, and then type the 

new name.  

You should give a meaningful name to each field, so that you can tell what it 

contains when you see it in the Field List pane. 

6. To move a column, click its heading to select the column, and then drag the 

column to the location that you want. You can also select multiple contiguous 

columns and then drag them to a new location all at once. To select multiple 

contiguous columns, click the column header of the first column, and then, 

while holding down SHIFT, click the column header of the last column.  

 

 

https://support.office.com/en-us/article/Create-a-new-database-32a1ea1c-a155-43d6-aa00-f08cd1a8f01e#__toc269904808
https://support.office.com/en-us/article/Create-a-new-database-32a1ea1c-a155-43d6-aa00-f08cd1a8f01e#__toc269904808


 

 

 

As you work through the following section it would be useful to try out the 

processes described so that you gain experience of using the database. 

1. Click the Create tab, and then click the Table Design button, or 
select the table you want to modify in the Navigation pane, and then 
click the Design View button.  

 

 

 

 

 

 

 

 

 

 

2. Click in a Field Name cell, and then type a modified field name. 
3. Click in a Data Type cell, click the Data Type list arrow, and then click 

a data type. 
4. Click in a Description cell, and then type a description. If the 

Property Update Options button appears, select an option, if 
necessary. 

5. To insert a field, click the row selector below where you want the 
field, and then click the Insert Rows button on the Ribbon. 

Practical Example 

Figure 1.18 create selection 

javascript:popUp('/content/images/chap3_9780789750471/elementLinks/03fig18_alt.jpg')


 

 

6. To delete a field, click the row selector for the field you want to 
delete, and then click the Delete Rows button on the Ribbon. 

7. Click the Save button on the Quick Access Toolbar, and then if 
necessary, enter a table name and click OK. 

Follow the steps below:  

Go ahead and create two tables as follows. 

 

 

Be sure to set a format and default value for the DateCreated fields on both 

tables (the user should not need to enter this field - the system can do that). 

 

Key icon indicates that the field is a primary key. A primary key ensures that the 
data in this field is unique - no two values can be the same. A table must have a 
primary key before a relationship can be established with another table. Access 



 

 

automatically sets the ID field as a primary key, so as long as you simply rename 
ID to ProductId (or OrderId as the case may be) it will already be a primary key. 
If for some reason your table does not have a primary key set, or if you want to 
change the primary key field, you can simply right click on the field header (in 
Design view), and select Primary Key from the contextual menu. 

Now that you have created two extra tables, our database has three tables. Now it 

is time to create the relationship between all three tables. 

1. While viewing a table in Design view, and ensuring that the DESIGN tab is 
selected, click Relationships from the Ribbon:  

 

 

Figure 1.19 relationship selection 

2. A Show Table dialog box will pop up, displaying all three tables. Select all of 
them and click Add:  

 

Figure 2.0 tables selection 



 

 

3. Click Close to close the dialog box 
4. You will now see three boxes which represent your three tables. Click and drag 

the CustomerId from the Customers table across to the corresponding 

CustomerId field on the Orders table:  

 

 

 

Figure 2.1 Customer ID selection 

It would be good to add some data and check that the database works as intended 

and to correct it if necessary. 

5. The Edit Relationships dialog will pop up. Click Enforce Referential 
Integrity so that it is checked. Check that the values are the same as the 
following screenshot and click OK: 

 

Figure 2.2 edit relationships selection 



 

 

You will now see a line established between the CustomerId field on the 
Customers table and the CustomerId on the Orders table.  

6. Now do the same for the Products table. That is, click and drag the 

ProductId from the Products table across to the corresponding 

ProductId field on the Orders table. Your table relationships should look 
like the ones in the following screenshot: 

 

Figure 2.3 products table selection 

 

Imagine you are running a company selling 50 different types of widgets all over 

the world. You have a client base of 1,250 and in an average month sell 10,000 

widgets to these clients. You are currently using a single spread sheet to track all of 

these sales – effectively a single database table. And every year adds thousands of 

rows to your spread sheet. 

 

Figure 2.4 images of the order tracking spreadsheet you are using  



 

 

The above images are part of the order tracking spreadsheet you are using. Now 

say both of these clients buy widgets from you several times a year so you have far 

more rows for both of them. 

If Joan Smith marries Ted Baines and takes his surname, every single row that 

contains her name now needs to be changed. The problem is compounded if you 

happen to have two different clients with the name ‘Joan Smith’. It has just become 

much harder to keep your sales data consistent due to a fairly common event. 

By using a database and normalizing the data, we can separate out items into 

multiple tables such as inventory, clients, and orders. 

 

Figure 2.5 orders and client table 

Just looking at the client portion of our example, we would remove the columns for 

Client Name and Client Address and put them into a new table. In the image above, 

things have broken up for a better granular access to the data. The new table also 

contains a column for a Primary Key (Client ID) – a number that will be used to 

access each row in this table. 

In the original table where we removed this data, we would add a column for a 

Foreign Key (Client ID) which is what links to the proper row containing the 

information for this particular client. 

Now, when Joan Smith changes her name to Joan Baines, the change only needs to 

be made once in the Client table. Every other reference from joined tables will pull 

the proper client name and a report that is looking at what Joan has purchased for 

the last 5 years will get all of the orders under both her maiden and married names 

without having to change how the report is generated. 

As an added benefit, this also reduces the overall amount of storage consumed. 



 

 

A join clause combines columns from one or more tables in a relational database. 

SQL defines five different types of joins: INNER, LEFT OUTER, RIGHT OUTER, FULL 

OUTER, and CROSS. The OUTER keyword is optional in the SQL statement. 

Microsoft Access allows the use of INNER (default), LEFT OUTER, RIGHT OUTER, and 

CROSS. FULL OUTER is not supported as such, but by using LEFT OUTER, UNION ALL, 

and RIGHT OUTER, it can be faked at the cost of more CPU cycles and I/O 

operations. 

The output of a CROSS join contains every row of the left table paired with every 

row of the right table. The only time one can see a CROSS join used is during load 

testing of database servers. 

Let us start by creating two tables, ProdA and ProdB, with the following design 

properties. 

 

The AutoNumber is an automatically incrementing long integer assigned to entries 

as they are added to the table. The Text option was not modified, so it will accept a 

text string up to 255 characters long. 

Now, populate them with some data. 

 

To show the differences in how the 3 join types work, delete entries 1, 5, and 8 from 

ProdA. 



 

 

 

Next, create a new query by going to Create > Query Design. Select both tables 

from the Show Table dialog and click add, and then Close. 

 

Click on ProductID in table ProdA, drag it to ProductID in table ProdB and release 

the mouse button to create the relationship between the tables. 

 

Right-click on the line between the tables representing the relationship between 

the items and select Join Properties. 



 

 

 

By default, join type 1 (INNER) is selected. Option 2 is a LEFT OUTER join and 3 is a 

RIGHT OUTER join. 

We will look at the INNER join first, so click OK to dismiss the dialog. 

In the query designer, select the fields we want to see from the drop-down lists. 

 

When we run the query (the red exclamation point in the ribbon), it will show the 

Product Name field from both tables with the value from table ProdA in the first 

column and ProdB in the second.  

 

Notice the results only show values where ProductID is equal in both tables. Even 

though there is an entry for ProductID = 1 in table ProdB, it does not show up in the 

results since ProductID = 1 does not exist in table ProdA. The same applies to 

ProductID = 11. It exists in table ProdA but not in table ProdB. 



 

 

 

Figure 2.6 select selection 

By using the View button on the ribbon and switching to SQL View, you can see the 

SQL query generated by the designer used to get these results. 

SELECT ProdA.ProductName, ProdB.ProductName FROM ProdA INNER JOIN 

ProdB ON ProdA.ProductID = ProdB.ProductID; 

Going back to Design View, change the join type to 2 (LEFT OUTER). Run the query 

to see the results.  

 

Figure 2.7 products A and B represented 

As you can see, every entry in table ProdA is represented in the results while only 

the ones in ProdB that have a matching ProductID entry in table ProdB show up in 

the results. 

The blank space in the ProdB.ProductName column is a special value (NULL) since 

there is not a matching value in table ProdB. This will prove important later. 

SELECT ProdA.ProductName, ProdB.ProductName FROM ProdA LEFT JOIN 

ProdB ON ProdA.ProductID = ProdB.ProductID; 

 



 

 

 

Figure 2.8 product table  

Try the same thing with the third type of join (RIGHT OUTER). 

The results show everything from table ProdB while it is showing blank (known as 

NULL) values where the ProdA table does not have a matching value. So far, this 

brings us closest to the results desired in our reader’s question. 

SELECT ProdA.ProductName, ProdB.ProductName FROM ProdA RIGHT JOIN 

ProdB ON ProdA.ProductID = ProdB.ProductID; 

 

The results of a function may also be returned as part of a query. We want a new 

column named ‘Results’ to appear in our result set. Its value will be the content of 

the ProductName column of table ProdA if ProdA has a value (it is not NULL), 

otherwise it should be taken from table ProdB. 

The Immediate IF (IIF) function can be used to generate this result. The function 

takes three parameters. The first is a condition that must evaluate to a True or 

False value. The second parameter is the value to be returned if the condition is 

true, and the third parameter is the value to be returned if the condition is False. 

The full function construct for our situation looks like this: 

IF (ProdA.ProductID Is Null, ProdB.ProductName, ProdA.ProductName) 

 

Notice that the condition parameter does not check for equality. A Null value in a 

database does not have a value that can be compared to any other value, including 



 

 

another Null. In other words, Null does not equal Null. Ever. To get past this, we 

instead check the value using the ‘Is’ keyword. 

We could have also used ‘Is Not Null’ and changed the order of the True and False 

parameters to get the same result. 

When putting this into the Query Designer, you must type the entire function into 

the Field: entry. To get it to create the column ‘Results’, you need to use an alias. 

To do this, preface the function with ‘Results:’ as seen in the following screenshot. 

 

Figure 2.9 product name selection 

The equivalent SQL code to do this would be: 

SELECT ProdA.ProductName, ProdB.ProductName, IF (ProdA.ProductID Is 

Null,ProdB.ProductName,ProdA.ProductName) AS Results FROM ProdA 

RIGHT JOIN ProdB ON ProdA.ProductID = ProdB.ProductID; 

 

Now, when we run this query, it will produce these results. 

 

Figure 3.0 query results 

Here we see for each entry where table ProdA has a value, that value is reflected in 

the Results column. If there isn’t an entry in the ProdA table, the entry from ProdB 

appears in Results  

 

 



 

 

Follow the steps as unit overview on creating a database.   

1. Click the Tables tab in the database window.   
2. Click New. 
3. The New Table Wizard appears.  
4. Select Table Wizard and click OK. 
5. Select the Personal toggle located above the Sample Tables column.  Select 

Addresses from the Sample Tables column (left click once to highlight.) 
6. Select First Name from the Sample Fields column (click once to highlight the 

selection.) Click the right pointing arrow button or double click the selection to 
add it to the Fields in My New Table column. 

7. Repeat step #6 with Last Name, Address, City, State, Postal Code, and Home 
Phone Number from the Sample Fields column. 

8. Click Next. 
9. The Table Wizard offers the name “Addresses” for your table; we’ll keep that 

name.  (On this same screen, there is a "YES" default for setting a Primary Key). 
Click Next.  

10. Click Finish and view your new table. 
11. Close the “Addresses” table (Click the X in the top right corner of the table 

window.) 
 

1. Click the Tables tab in the database window. 
2. Double click Addresses to open the table we have created. In the table fields, 

ignore the one labeled Addresses ID for now. 
3. Press the right arrow key or tab key and enter these field values, pressing enter 

after each value: 
 

First 

Name 

Last Name Address City  State ZIP  Phone # 

Betty  Bop Akobo Jonglei SS  72213 (+211) 005555 

Daffy  Duck Buragwa Jonglei SS 72213 (+211)119999 

Mickey  Mouse Korial Jonglei SS 72213 (+211)225555 

 

4.   Click Save and close the table. 



 

 

1. Click the Forms tab in the database window. 
2. Click New. 
3. The New Form Window appears. 
4. Select Form Wizard and click OK. 
5. Click the two right pointing arrows button to move all the fields over to the 

right side of the window. 
6. Select Address ID and click the left pointing arrow button to move it back over 

to the Available Field side of the window. 
7. Click Next. 
8. Select Columnar; Click Next.  Select Standard style; Click Next. 
9. The wizard offers “Addresses” for the form title, which is fine.  
10. Click Finish and view the form. 
11. Click the right pointing arrow button at the bottom of the form window (next to 

the Record: box).   Click this arrow two more times and notice the entries.  The 
form should be empty on the fourth record.   

12. Click Save and close the form. 
 

In Access, you can enter data into Tables or Forms.  Let us use the form we just 

created to enter more data. 

1. Click the Forms tab in the database window 
2. Double click “Addresses” to open the form. 
3. Click the right pointing arrow with a star button at the bottom of the form.  The 

form should be on the fourth record, which is blank.  Enter the following field 
values.  Press the enter key or tab key after each entry to move to the next cell. 

 

First 

Name 

Last 

Name 

Address City  State ZIP Code Phone # 

Sponge  Bob Abwong Upper Nile SS 71100 (+211)440022 

 

4. Betty Bop is spelled incorrectly.  Click the left arrow with a line button at the 
bottom of the form.  This will automatically take you to the first record. 

5. Click the Last Name text box with the word “Bop.”  Click before the “p” and 
enter “o.”  It should now read “Boop.” 

6. Click Save and close the form. 



 

 

7. Access should automatically update the table with the new form data.  Click the 
Tables tab and double click Addresses to open the table 

8. You should see the Sponge Bob record and the spelling correction of “Boop” in 
the table. 

9. Click Save.  
10. Close the table (click the X in the top right hand corner of the window.) 
 

Let us find the people in our Address Book database that live in Houston.  We are 

planning a last minute birthday party and need to call them immediately.  We have 

four records in our database.  If there were more records, it would be time 

consuming to go through all the addresses.  Queries allow you to pluck only certain 

pieces of data out of your database.  Let us make a query to find the people in our 

database that are located in Houston.  

1. Click the Queries tab in the database window. 
2. Click New. 
3. The New Query Window appears.  Select Simple Query Wizard and click OK 
4. Click the downward pointing arrow on the right of the Tables/Queries: text box. 
5. Select Table: Addresses. 
6. Select First Name, Last Name, City, and Home Phone  field values (click once to 

highlight the selection and then click the right pointing arrow or double click 
the selection) and move to the Selected Fields side of the window.  

7. Click Next. 
8. Under “What title do you want for your query?” type: Houston in the text box 

and click Finish. 
9. The results are displayed.  The records are displayed with four fields that were 

included in the search. We only want the records that include the city Houston.  
We have a little more work to do. 

10. Select query Houston already created. Click on Design icon on the toolbar to 
look at the query in Design View. 

11. At the bottom half of the screen there is a grid.  Under the City column and 
along the Criteria row, we want to type: Houston in that cell.  We are making a 
query, which looks for only those records that include Houston – not the friends 
that live in Humble, for example. 

12. Click the Run tool (red exclamation point) on the tool bar to get the results of 
the query. 

13. The records that include Houston are displayed.  Now we know who to call and 
their phone number. 

14. Click Save and close the database window. 
15. Close Access. 



 

 

Create a database file, which will require you to create one table, one query, one 

form, and one report.     

Create table: CUSTOMERS 

Create  the  field  names  and  their  properties  as  you  need  them  to  store  your  

specific  data  for  customers.  You  will  have at  least five  customers  with  their  

information  included  in  your  customer table.   

CUSTOMERS Table Field Names: 

Customer ID (Primary Key: CID) 

First Name (FNAME) 

Last Name (LNAME) 

City (CITY) 

State (STATE) 

Number of Purchases (PNUMBER) 

Total Amount of Purchases (PTOTAL) 

Date of Last of Purchase (PLAST) 

Create query: NY Customers 

Create a query that displays only the MSA customers sorted by last name in 

ascending order. 

Create report: NY Customers Report  

Create a report from the NY Customers query.   

Create form: New Customers 

Create a form for the Customers table. Include all fields in the form. Use the Form 

Wizard to create a form. Using the New Customers form, enter two additional 

customers:  

Mathieu Alfa Birir    NRB 3 $150.00 March 12, 2010 

Jennifer Cherbich   MSA 2 $250.00 March 17, 2010 

 



 

 

 

This is an enterprise resource planning system for a library, used to track items 

owned, orders made, bills paid, and patrons who have borrowed. Enterprise 

resource planning provides an integrated and continuously updated view of core 

business processes using common databases maintained by a database 

management system. 

 

Figure 3.1 integrated library system (library Management system). 

Larger libraries use an integrated library system to order and acquire, receive and 

invoice, catalogue, circulate, track and shelve materials. Smaller libraries, often 

forgo the expense and maintenance required to run an ILS, and instead use a 

library computer system.  

 



 

 

 

Figure 3.2 Sequence diagram for issuing book 

An Integrated library system ILS usually comprises of a relational database, 

software to interact with that database, and two graphical user interfaces (one for 

patrons, one for staff). Most ILSes separate software functions into discrete 

programs called modules, each of them integrated with a unified interface. 

Examples of modules might include: 

 Acquisitions (ordering, receiving, and invoicing materials) 

 Cataloguing (classifying and indexing materials) 

 Circulation (lending materials to patrons and receiving them back) 

 Serials (tracking magazine, journals, and newspaper holdings) 

 The OPAC (public interface for users)  



 

 

1. Explain how you can import data from other sources into Access database? 

2. What are the types of relationship can be formed between different data? 

3. Explain how you can build a relationship between the different databases in 

Access? 

4. Name some of the file extension for MS Access? 

5. What are queries in database? 

6. Explain what joins are and how you can open the database in Access? 

7. Mention how you can create a simple query in Access 2013? 

8. Explain how you can export data in Excel format? 

9. Explain how you can create a form in Microsoft Access 2013? 

10. In MS Access 2013 what are the different ways you can enter data? 

11. Explain the use of WHERE clause in MS Access SQL? 

12. Explain how you can do multi-join query in MS Access? 

13. Explain how MS Access is better than MS SQL Server? 

14. What things to be taken in consideration for lookup fields? 

 
  



 

 

 

 

SPECIFIC LEARNING OUTCOMES 

By the end of this unit you should; 

 Know how to use advanced formatting techniques to edit and produce 

word-processing and presentation documents, e.g. MS Word and 

PowerPoint. 

 Use advanced features in producing documents 

 Be able to create and manage a complex document to a high quality 

standard 

Key inquiry questions 

1. What is advanced formatting?  

2. What are functions and macros and how are they used? 

3. How are templates created and used? 

4. How is a table of contents for a document created? 

5. How are diagrams, tables, and images included in documents? 

6. How are hyperlinks incorporated into documents? 

7. How are multimedia products produced? 

  



 

 

1. Open or navigate to the MS Word (the version that is available to you)   
interface. 

2. Click through all of the tabs, and review the commands on the Ribbon. 
3. Try minimizing and maximizing the Ribbon. 
4. Add a command to the Quick Access toolbar. 
5. Hide and show the Ruler. 
6. Navigate to Backstage view, and open your Account settings. 
7. Try switching document views. 
8. Close Word (you do not have to save the document).  

 

Advanced formatting improves the readability of your documents and often 

provides visual clues to the document's purpose.  

Advanced Formatting Techniques for example in Excel 2010, makes spreadsheet 

information readable and understandable, from emphasizing specific cells to 

adding style and readability to worksheets. It also covers automation techniques 

that take the work out of formatting even the largest amounts of data. 

 

In pairs 

Practise using all the text editing and formatting features of MS Word and MS 

PowerPoint. 

Presentation 

Develop a Power Point presentation demonstrating MS Word and MS PowerPoint 

capabilities. 

 

 

 

Microsoft word is used to create and edit professional-looking documents such as 

resumes, books, admission forms, letters, papers, reports and booklets, cover 

pages, notes, assignments, brochures and even web pages, it includes a number of 



 

 

automated tools to help standardize the formatting and layout of large, complex 

documents. There are times that call for a more sophisticated level of formatting in 

a MS word document, this seldom-used formatting trick adds an even higher level 

of professionalism in a document. 

The best way to see the structure of the document is with the Navigation Pane. (In 

some versions of Word for Mac, it may be called the Document Map Pane.) 

In Windows, go to the View tab, then click the check box to enable the Navigation 

Pane. 

 

As you work through the following section it would be useful to try out the 

processes described so that you gain experience and build your skills in advanced 

formatting techniques.

In Windows, go to the References tab on the ribbon, click the Table of Contents 

button on the left, and then choose one of the two built-in tables from the list. 

Note that the thumbnails show that Headings 1, 2 and 3 will be included. 

It is almost the same on the Mac. Go to the Insert menu, choose Index and Tables, 

then pick one of the formats on the left and click OK. This dialog box also shows 

that Headings 1-3 will be included. 

Practical Example 



 

 

 

Figure 3.3 generating a table of contents 

You can insert a table of contents in Word just by clicking one of the samples. 

As soon as you choose one, the table of contents gets inserted starting on page 2, 

and Word automatically inserts a couple more pages, so it all fits. In Windows, you 

can Ctrl-click one of the items, and it will hyperlink to the item in the document. 

 

Figure 3.4 updating a table of contents 

A table of contents is a field that you can update in MS Word. In Windows, fields 

have a grey background. 

Before the Introduction, there is a Preface that should be included in the table of 

contents. And just before Appendix A1 is the heading for the Appendix, and that 

should also be included. But they were not, because they are both formatted with 

a custom style called large heading, and custom styles do not get included in the 



 

 

default table of contents. The second method of creating table of contents in Word 

will fix that. 

Word can include any styles in a table of contents. We just have to tell it which 

ones to choose. And we can update the table, rather than having to delete it and 

start over. 

In Windows, go back to the References tab, click the Table of Contents button, 

then near the bottom of the menu, and choose Custom Table of Contents. Click 

the Options button near the bottom of the dialog box to display the Table of 

Contents Options dialog box. 

On the Mac, go to back to the Insert menu and choose Index and Tables. In the 

Table of Contents section, click the Options button. On the Mac or PC the Table of 

Contents Options dialog box shows that the Heading 1 style will have TOC level 1, 

the Heading 2 style will have TOC level 2, and the Heading 3 style will have TOC 

level 3. 

 

Figure 3.5 Creating a Table of Contents from Custom Styles 

Word uses its built-in styles to determine what goes into the table of contents. 

(Windows example) 



 

 

Scroll down to the bottom of the list (on the Mac, you will use the down slider). 

Then, in the box for Large heading, type a 1 to make it level 1. Table of Content 

levels can come from more than one style. 

 

Figure 3.6 including a custom style in the table of contents 

To include a custom style in the table of contents, assign a heading level to it. 

Click OK in the Table of Contents Options dialog, then OK again in the Table of 

Contents dialog box. When Word displays a message asking if you want to replace 

the table, choose yes. The Preface and Appendix are now both included in the table 

of contents. 



 

 

 

Figure 3.7 text formatted with styles 

After adding custom styles to the TOC list, text formatted with those styles will 

appear in the table. 

There are other times when you will want to update the table manually. This is 

handy when you change the text of one of the headings and want the change 

reflected in the table of contents. 

Scroll down to the page with the preface. At the top of the page replace PREFACE 

with FORWARD. Make sure it still uses the Large heading style. 

Go back to the top of the table of contents and click in it. Note that it has a grey 

background; that means it is a field, and fields can usually be updated.  

Click the Update Table button either on the TOC itself (that button does not always 

appear) or on the References tab, and the first entry changes to FORWARD. (On the 

Mac, right-click the table and choose Update Field from the pop-up menu. Choose 

the Update entire table option and click OK.) 



 

 

 
Figure 3.8 updating a table in mac 

 

 

When you insert a graphics object of any sort into a Word document—pictures, clip 

art, charts, SmartArt—it is inserted in line with the text on the text layer.  Word 

treats it as just another character of text.  When you drag it to a new location 

within your text it acts just like a character on that line, within that paragraph.  But 

sometimes what you want is a graphic that the text flows around, book or 

magazine style, and often then has special needs to display the text in very specific 

patterns near or around the art work. 

Word has both a text layer and a graphics layer.  Text cannot wrap around the 

graphic until it is moved to the graphics layer.  Your graphic is moved to the 

graphics layer when you choose a text wrap option other than inline.  All of the 

other options make it a ‘floating’ graphic, rather than an inline graphic, which 

means it can be moved anywhere you wish. 

To apply another text wrap option select the graphic, then on the Picture Tools tab 

select the option you wish from among six presets: Square, Tight, Through, Top and 

Bottom, Behind Text or In Front of Text. 



 

 

 

Figure 3.9 wrap text selection  

Selecting behind Text will place your graphic on the layer behind the document 

text. 

The other four vary a bit, and their names are descriptive of their function.  Square 

and tight are the same, except that Square keeps text outside the actual 

rectangular borders of the graphic.  Tight allows text into any transparent 

background areas within the graphic’s borders.  Through is another odd choice, and 

is little used, and in truth varies little from Tight.  Top and Bottom is simply a 

variation on Square with one of the More Layout Options… chosen. 

Selecting that menu choice brings up the following dialog: 



 

 

 

Figure 4.0 dialog after selecting the menu choice 

The Wrap text and Distance from text options will only be available if you have 

already changed the Wrapping style from Inline to one of the other choices. 

The Left only and Right are the only choices useful when inserting an Excel chart, 

positioning it slightly to one side of a document, but not all the way to the margin, 

and flowing text down a single side of it. 

Edit Wrap Points gives ultimate control to text wrap around a graphic.  Click it and a 

red border appears around your graphic. 

 

Figure 4.1 red border selection 

Place your cursor anywhere on the red border and drag to control text wrap with 

precision. 



 

 

 

Figure 4.2 wrap points 

If Wrap Points are dragged inside the field of the graphic, text flows there.  When 

the wrap points are far outside, the text stays away.  This is the ultimate in 

control.  Remember, it is only available once you have chosen one of the non-Inline 

wrapping options. 

These options are also available on the graphic’s context menu too.  Simply right-

click the graphic, move your cursor down to Wrap text, and a sub-menu with the 

same choices will appear. 



 

 

 

Figure 4.3 wrap text selection 

To gain control over text wrap in your document, select your graphic and choose a 

non-Inline layout style to move it to the graphics layer where it can float; drag the 

graphic approximately where you want it; use the Layout Options to control major 

text flow control; if you need very fine tuning edit the Wrap Points. 

 

As you work through the following section it would be useful to try out the 

processes described so that you become familiar with the formatting techniques. 

1. Open a blank document in Print Layout view, right-click the Standard 

toolbar, click Drawing. 

2. Click the Text Box tool in the Drawing toolbar and click and drag across the 

top of the page where you wish to insert the picture. 

3. Underneath the picture text box, insert two vertical text boxes: one for the 

article text and a second for the events calendar. 

4. Insert a hard page break. On page two of your document, insert two vertical 

text boxes — one on each side of the page. 

5. Click the first vertical text box on page one. Right-click the Standard toolbar 

and click Text Box. 

6. On the Text Box toolbar, click the Create Text Box Link tool. 

Practical Example 



 

 

7. Move the pointer (which is now shaped like a pitcher) to the second vertical 

text box on page two. When the pitcher turns into a pouring pitcher, click 

the second text box to link it with the first. 

8. Click the second text box, which you linked to the text box on page one. 

Click the Create Text Box Link tool. 

9. Move the pointer to the third vertical text box on page two. When the 

pitcher turns to become a pouring pitcher, click the third vertical text box. 

 

1. Create a new Word document.  
2. Insert a picture from a file into the document. 
3. Resize the picture. 
4. Find a picture with Bing Image Search and insert it into your document. Or 

search for computer and insert. 
5. Change the text-wrapping setting of one of the images. If you are using the 

change the text-wrapping setting of the computer to through. 
6. Try moving an image to a new location. 

 

If you have already had some text formatted just the way you want it, you can use 

it to create a new Style. The easiest way is to select the text you want the Style to 

emulate, right-click and select Styles, then select Create a Style: 



 

 

 

 

 

 

 

 

 

http://legalofficeguru.com/wp-content/uploads/2016/08/Word-2016-create-Style-from-example-1.png


 

 

You will get this dialog box: 

 

You could simply click OK here, but you could also see what your options are in 

case you want something other than the defaults Word will choose for you: 



 

 

 

1. Word will automatically name this Style1; you will want to rename it here if 
you did not already do it in the previous dialog box. 

2. Word has several Style types: Paragraph, Character, Linked (which combines 
Paragraph and Character), Table and List. Since this is really intended to be 
a collection of paragraph settings, Linked isn’t really the best choice, 
because if I change the font style or size elsewhere in the document and 
apply Block Quote as a Linked Style, it is going to change the text back to 
Calibri 11. The Style type Paragraph is a better choice in this instance. 

3. If I’m typing a Block Quote paragraph and I press the Enter key, what Style 
do I want the following paragraph to default to? It is a matter of personal 



 

 

convenience and obviously depends on what sort of document you are 
working on. 

4. And you can review the settings themselves in this window. 
5. These settings control three things:  

a) Whether you can access this Style in the Styles Gallery on the Home 
tab (if you want to keep this one handy, leave that box checked);  

b) Whether you want any Styles to automatically update themselves 
based on manual formatting you do in your document (for example, if 
you altered the indentation on one paragraph that had the Block 
Quote Style applied to it, checking this box means that the Style itself 
reflects those changes, and all the paragraphs with Block Quote 
applied will change, not just the one you edited). I recommend leaving 
this one unchecked—it tends to wreak havoc in documents;  

c) Whether you want this Style to be available only within this document 
or any documents you create in the future in this template. 

6. You can make further format changes to your Style settings in both these 
places. The area at the top will let you make some font and spacing 
changes, but Format button will take you to various dialog boxes 
(Paragraph, Numbering, etc.) for more advanced formatting. 

Once you have configured everything to your liking, click OK. 

If you have got a specific set of requirements and are fairly skilled with character 

and paragraph formatting, though, you can simply create a new Style from scratch.  

To start, click the drop-down arrow at the bottom right-hand corner of the Quick 

Styles area to open the Styles pane: 

 

Figure 4.3 style selection 

Then click Create a Style: 



 

 

 

Figure 4.4 creating a new style 

You will get the now-familiar dialog box: 

 

Figure 4.5  creating a new style from formatting 



 

 

You will notice that it is designated to be a Paragraph Style. Since this Style is 

intended to control how the text indents and spaces, you want it to be 

independent of font settings, etc., so you can use it with any font settings in any 

document. 

To get those indents and spacing, click on the Format button at the bottom and 

choose Paragraph to go to the Paragraph dialog box: 

 

Figure 4.6 preview pane 

You can preview the results in the Preview pane. 

When you want to see who’s been making changes to your document, turn on the 

Track Changes feature. 



 

 

As you work through the following section it would be useful to practise tracking 

changes so that you become familiar with this valuable option.

On the Review tab, in the Tracking group, choose Track Changes. 

When you turn on Track Changes, Word marks up new changes made to the 

document. This is particularly useful when more than one person is working on a 

document. Track Changes allows each person to easily see the changes that have 

been made to the document. 

When you turn off Track Changes, Word stops marking up new changes. Any 

changes that were already tracked remain marked up in the document until you 

remove them. 

 

Figure 4.7 track changes selection 

When you turn on Track Changes, Word marks up and shows any changes that 

anyone makes to the document.  

Practical Example 
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Figure 4.8 changes made on a document 

1. On the Review tab, in the Tracking group, in the Simple Markup list, choose 

a view option. 

Simple Markup is the default option, and indicates where changes are with a 

red line in the margin. 

 

 No Mark-up hides mark-up to show what the incorporated changes 
will look like. 

You can see the markup again by choosing Simple Markup or All Markup. 

 All Markup shows all edits with different colors of text and lines. 

 Original shows the document in its original form. 

2. In the Show Markup list, choose the revisions you'd like to see—Comments, 

Ink, Insertions and Deletions, Formatting, Balloons, Specific people. 

You can prevent someone else from turning off Track Changes by turning on Lock 

Tracking and adding a password. When Tracked Changes is locked, you cannot turn 

off the feature, and you cannot accept or reject the changes. 

1. On the Review tab, in the Track Changes list, choose Lock Tracking. 
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Figure 4.9 lock tracking selection 

Do one of the following: 

 In the Lock Tracking dialog box, enter a password, type it again in the Re-

enter to confirm box, and then choose OK. 

Adding a password is optional. It is not a security feature. It is intended, 

however, to discourage others from turning off Track Changes. 

 In the Lock Tracking dialog box, choose Cancel. 

Turn off Lock Tracking  

1. In the Track Changes list, choose Lock Tracking. 

2. If you added a password, enter it when prompted, and then choose OK.  

3. Track Changes is still on, but you can accept and reject changes. 

The only way to remove tracked changes in a document is to accept or reject them. 

Choosing No Markup in the Display for Review box helps you see what the final 

document will look like—but it only hides tracked changes temporarily. The 

changes are not deleted, and they will show up again the next time anyone opens 

the document. To delete the tracked changes permanently, accept or reject them. 

Accept or delete a single tracked change  

1) Open your document. 

2) On the Review tab, in the Changes group, choose Next or Previous.  

3) Choose Accept or Reject. 
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Figure 5.0  review tab selection 

Accept or delete all tracked changes  

1. Open your document. 

2. On the Review tab, in the Changes group, do one of the following:  

 In the Accept list, choose Accept All Changes. 

Or 

 In the Reject list, choose Reject All Changes. 

 

 

If you frequently create a certain type of document, such as a monthly report, a 

sales forecast, or a presentation with a company logo, save it as a template so you 

can use that as your starting point instead of recreating the file from scratch each 

time you need it. Start with a document that you already created a document you 

downloaded, or a new template you customized. 

 

 

As you work through the following section it would be useful to follow the steps on 

the computer so that you become familiar with the use of templates. 

1. To save a file as a template, click File > Save As. 

2. Double-click Computer or, in Office 2016 programs, double-click This PC. 

Practical Example 



 

 

 

3. Type a name for your template in the File name box. 

4. For a basic template, click the template item in the Save as type list. In Word 

for example, click Word Template. 

 

If your document contains macros, click Word Macro-Enabled Template. 

Office automatically goes to the Custom Office Templates folder. 

5. Click Save. 

To change where your application automatically saves your templates, click File > 

Options > Save and type the folder and path you want to use in the Default 

personal templates location box. Any new templates you save will be stored in 

that folder, and when you click File > New > Personal, you will see the templates in 

that folder. 

To update your template, open the file, make the changes you want, and then save 

the template. 



 

 

1. Click File > Open. 

2. Double-click Computer or This PC. 

3. Browse to the Custom Office Templates folder that’s not under My Documents. 

4. Click your template, and click Open. 

5. Make the changes you want, then save and close the template. 

To start a new file based on your template, click File > New > Personal, and click 

your template. 

 

Figure 5.1 personal selection 

In pairs 

Create a job resume with all the features included. 

Presentation 

Present the resume to the class. Which pair has the best resume? 

 

 

In Office, you can use a password to help prevent other people from opening or 

modifying your documents, workbooks, and presentations. Then you can easily 

remove passwords to unprotect a document or workbook if read only is no longer 

required. Also, you can use document protection to restrict the types of changes 

that reviewers can make. 

 



 

 

 

As you work through the following section it would be useful to practise protecting 

your word documents. 

 In an open document, click File > Info > Protect Document. 

 

 

 

 

 

 

 

 

 

 

When a document is marked as final, typing, editing, commands, and proofing 

marks are disabled or turned off and the document becomes read-only. The Mark 

as Final command helps you communicate that you are sharing a completed 

version of a document. It also helps prevent reviewers or readers from making 

inadvertent changes to the document. 

When you mark a document as final, Word asks you to save the file. The next time 

you open it, you will see a yellow MARKED AS FINAL message at the top of the 

document. If you click Edit Anyway, the document will no longer be marked as 

final. 

 

 

Practical Example 

Figure 5.2 document protection 
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Important: Keep your password in a safe place. If you lose or forget the password, 

it cannot be recovered. 

When you select Encrypt with Password, the Encrypt Document dialog box 

appears. In the Password box, type a password, and then type it again when 

prompted. Important: Microsoft cannot retrieve lost or forgotten passwords, so 

keep a list of your passwords and corresponding file names in a safe place. 

1. Restrict Editing:    Control what types of changes can be made to the 

document. 

When you select Restrict Editing, you see these options: 

 Formatting restrictions reduces formatting options, preserving a look and 

feel. Click Settings to select which styles are allowed. 

 Editing restrictions you control how the file can be edited or you can 

disable editing. Click Exceptions or More users to control those who can 

edit. 

 Start enforcement    Click Yes, Start Enforcing Protection to select 

password protection or user authentication. You can also click Restrict 

permission to add or remove editors who’ll have restricted permissions. 

 Restrict Permission by People:    Use Windows Live ID to restrict 

permissions. 

 Use a Windows Live ID or a Microsoft Windows account to restrict 

permissions. You can apply permissions via a template that is used by your 

organization, or you can add permissions by clicking Restrict Access. 

2. Add a Digital Signature: Add a visible or invisible digital signature. 
Digital signatures authenticate digital information such as documents, email 
messages, and macros by using computer cryptology. Digital signatures are 
created by typing a signature or by using an image of a signature to establish 
authenticity, integrity, and non-repudiation. 
 

 

 

As you work through the following section it would be useful to try out the mail 

merging processes described. 

Mail Merge is most often used to print or email form letters to multiple recipients. 

Using Mail Merge, you can easily customize form letters for individual recipients. 

Mail merge is also used to create envelopes or labels in bulk. 



 

 

1. In a blank Microsoft Word document, click on the Mailings tab, and in the 
Start Mail Merge group, click Start Mail Merge 

 

 

Figure 5.3 starting mail merge 

 

2. Click Step-by-Step Mail Merge Wizard. 

 

Figure 5.4 Step-by-Step Mail Merge Wizard 

3. Select your document type. In this demo we will select Letters. Click Next: 
Starting document.  



 

 

 

4. Select the starting document. In this demo we will use the current (blank) 
document. Select Use the current document and then click Next: 

Select recipients.  

 

 

 



 

 

 Note that selecting Start from existing document (which we are not doing 

in this demo) changes the view and gives you the option to choose your 

document. After you choose it, the Mail Merge Wizard reverts to Use the 

current document. 

5. Select recipients. In this demo we will create a new list, so select Type a 
new list and then click Create.  

 

 Create a list by adding data in the New Address List dialog box and clicking 
OK.  

 

Figure 5.5 creating a list by adding data in the New Address. 



 

 

 Save the list. 

 Note that now that a list has been created, the Mail Merge Wizard reverts 
to Use an existing list and you have the option to edit the recipient list. 
 

 
 Selecting Edit recipient list opens up the Mail Merge Recipients dialog box, 

where you can edit the list and select or unselect records. Click OK to accept 
the list as is.  

 

 

Figure 5.6 Selecting Edit recipients 



 

 

 Click Next: Write your letter.  
 

 
6. Write the letter and add custom fields.  

 Click Address block to add the recipients' addresses at the top of the 
document. 
 

 

 In the Insert Address Block dialog box, check or uncheck boxes and 
select options on the left until the address appears the way you 
want it to.  



 

 

 

 

Figure 5.7 Inserting Address Block dialog box 

 Note that you can use Match Fields to correct any problems. Clicking 
Match Fields opens up the Match Fields dialog box, in which you can 
associate the fields from your list with the fields required by the 
wizard.  

 

 

Figure 5.8 match field selection 

7. Press Enter on your keyboard and click Greeting line... to enter a greeting.  

 



 

 

 

8. In the Insert Greeting Line dialog box, choose the greeting line format by 
clicking the drop-down arrows and selecting the options of your choice, and 
then click OK.  

 

 

Figure 5.9 greeting line format selection 



 

 

9. Note that the address block and greeting line are surrounded by chevrons 
(« »). Write a short letter and click next: Preview your letters.  

 

 

Figure 6.0  preview your letter selection 

 

 Preview your letter and click next: Complete the merge.  
 

 
Figure 6.1 complete the merge selection 



 

 

 Click Print to print your letters or Edit individual letters to further 
personalize some or all of the letters. 

 
 

Applies To: Excel 2016 Word 2016 Outlook 2016 PowerPoint 2016 Office 2016 

The fastest way to create a basic hyperlink in an Office document is to press ENTER 

or the SPACEBAR after you type the address of an existing webpage, such as 

http://www.mountainpublishers.com. Office automatically converts the address 

into a link.  

In addition to webpages, you can create links to existing or new files on your 

computer, to email addresses, and to specific locations in a document. You can also 

edit the address, display text, and font style or color of a hyperlink.  

When it is not convenient to have Office automatically create hyperlinks in your 

document as you type, you can turn them off. 

1. In Office 2010 and later:  

Click File > Options > Proofing. 

(In Outlook, click File > Options > Mail > Editor Options > Proofing.) 

In Office 2007:  

Click the Microsoft Office button, and then click Options > Proofing. 



 

 

(In Outlook, open a new message, click the Microsoft Office button, and then 

click Editor Options > Proofing.) 

2. Click AutoCorrect Options, and then click the AutoFormat as You 

Type tab. 

3. Clear the Internet and network paths with hyperlinks check box. 

  In groups 

1. What are the uses of Microsoft Word in Business and 

workplace? 

2. What are uses of MS word in Education? 

3. What are Home based uses of Microsoft Word? 

  Discuss 

  Write your answers and be ready to explain your answers, discuss with your group 

to find the similarities of your answers. As a group write answers in form of a 

presentation. Make the presentation to the class. 

 

Learning objectives: 
The learners should be able to: 

 Identify the names and functions of the PowerPoint interface. 
 Create, edit, save, and print presentations. 
 Format presentations. 
 Add a graphic to a presentation. 
 Create and manipulate simple slide shows with outlines and notes. 
 Create slide presentations that include text, graphics, animation, and 

transitions. 
 Use design layouts and templates for presentations. 
 Create a PowerPoint presentation. 

Slides need to be consistent by enhancing creativity by reducing the unnecessary 

attention in PowerPoint slides. The inconsistency that should be eliminated from 



 

 

e.g. business presentations is the unintentional oversights in PowerPoint design, 

not deliberate ones that are designed to emphasize a key point or concept.  

There are five areas of presentation design that can benefit from greater 

consistency. 

1. Colours: You do not want to use every colour in the rainbow in your slides. 

Your presentation will look more professional if you limit yourself to only 

using a subset of colours consistently throughout your slides. If your 

PowerPoint template is well-designed, you can leverage its built-in theme 

colours. 

2. Fonts: There are many fonts in Microsoft Office, but your presentation 

slides should not include more than three of them in one slide deck. If too 

many fonts are used in one PowerPoint presentation, they can become a 

distraction and dilute the effectiveness of your message. If you are using 

multiple fonts, try to use them the same way throughout your slides (e.g., 

body text, text boxes, slide titles, etc.). 

3. Images: Some presentations can end up looking like misguided elementary 

school collages. When you are looking to use several images throughout 

your presentation, you can improve its professional look and feel by 

choosing pictures and clip art that are similar in style. You may also want to 

consider repeating a particular graphic throughout a presentation rather 

than using multiple images to represent the same point or concept.  

4. Formatting: Consistent formatting can be a real problem when you are 

incorporating slides from someone else. A business or academic 

presentation can look disjointed and less professional when a presenter 

does not take the necessary time to clean up the formatting. In order to 

improve the professional polish of your presentation design, you need to 

invest some time in making sure that the formatting of fonts, images, bullet 

points, animations, backgrounds, etc. is consistent. 

5. Content: As you build out your content, you may want to consider using a 

consistent approach or structure. For example, if you are examining several 

problems in your research, you may want to follow a uniform approach as 

you present your findings (e.g., problem description, analysis, 

recommendations). In terms of content consistency as an example using 

bullet points in a consistent manner on the slides where that approach is 

used. 

 

 



 

 

Some presentations, like keynote presentations, are meant to be more flashy. They 

are usually short on details and long on big concepts. They incorporate an 

entertainment value. These are sometimes called ballroom presentations. The 

audience might be fairly large. 

Other presentations, like internal or sales presentations are very different. They 

require more details, including graphs and statistics, and they are not meant to 

entertain. The audience is usually smaller, so there’s more opportunity for 

interaction. The purpose is usually to persuade or train. 

The style that you would use for a keynote presentation is different from the style 

that you would use for a sales, training, or in-house presentation. But more than 

that, you must have noticed as an audience member that presenters have different 

styles. 

Some presenters put a big idea on a slide and then spend quite a bit of time 

discussing that slide. Each slide is a springboard for a lot of content. Other 

presenters go through their slides very quickly. Each slide contains just a sliver of 

content and they build up their content with many slides.  

Multimedia means combining multiple types of media in your presentation. You 

can use combinations of images, audio, and video to make your point. 

Every PowerPoint slide is a blank canvas, waiting content to reinforce key speaking 

points or guide the presentation. Multimedia brings variety to your slides and helps 

visual learners understand your content better.  

If we were bound to using only text and shapes, it would be much harder to hold 

an audience's attention during a presentation. 

Multimedia exists to help reinforce our key speaking points. Here are a few ideas 

for working with images, audio, and video to make your presentation more 

interesting: 

 Images - These could be used for everything from simple stock photos that 

add slide variety, to logos and icons that showcase your brand. 

 Audio - is a great way to add narrations to your slides if you cannot present 

directly to your audience or to add music and sound effects. 



 

 

 Video - You can add video clips from your computer or sites like YouTube. 

Videos could be used for showing instructional walkthroughs from YouTube, 

TED talks, or a recorded screencast of your own.  

 

 

As you work through this section it would be useful to follow the steps on the 

computer so that you develop your Powerpoint skills. 

The simplest way to add an image to PowerPoint is to simply copy and paste.  You 

can copy an image to your clipboard in practically any app like a web browser or 

image editor, and then right click to paste it into PowerPoint. 

A better way to insert images is to save them to your computer, then insert them 

using the Insert menu. Go to the Insert > Pictures menu to browse to an image to 

insert. 

 

Figure 6.2 insert menu selection 

Insert an image from the Insert > Pictures menu on the PowerPoint ribbon. 

On the pop-up menu, browse to where your images are stored and click on them to 

add them to the presentation.  

The best thing about using the Insert menu is that you can add multiple images at 

the same time. Hold the Control button on your keyboard and click on multiple 

images before you press Insert to add them all to a slide. 



 

 

 

Figure 6.3 inserting an image 

Select multiple images by holding Control on your keyboard and clicking on them 

before pressing Insert to add them all to a slide. 

Once an image is on the slide, you can click and drag it to move it around on the 

slide. If the image is larger or smaller than you want, you can click and drag on the 

corner to resize it.  

 

Figure 6.4 resizing an image 



 

 

Click and drag the white circle on the corner of an image to resize it on your 

PowerPoint slide. 

PowerPoint also includes a set of tools to edit images from within the app. You do 

not always have to open up Photoshop or another editor to make basic changes to 

your images.  

When you select an image, you will see a new option on the PowerPoint ribbon. 

Click on “Picture Tools > Format” to open up image editing tools. 

 

Figure 6.5 picture format selections 

Here are the key Picture Tools to try out: 

 Cropping - Select a portion of the image that you want to keep (and 

remove) to trim an image inside PowerPoint. 

 Remove background - If you have a logo with a white or black background, 

use this wizard to isolate the logo. 

 

Audio is another multimedia type you can work with in PowerPoint.  

If you have an audio track on your computer like an MP3 or WAV file, you can 

easily add them to your presentation. Choose the Insert > Audio > Audio on My 

PC option to browse for and choose an audio file. 

 

Figure 6.6 adding an audio file to PowerPoint 



 

 

Go to Insert > Audio > Audio on my PC option to browse for and choose an audio 

file to add. 

After you choose the audio file, you will see a small speaker icon on your 

PowerPoint slide. You can hover over it and press the play button to play it while 

presenting. 

If you do not already have your audio recorded in a file, you can actually capture it 

right inside of PowerPoint. 

To record audio for the presentation, go to the Insert > Audio > Record 

Audio option. 

 

Figure 6.7 record audio selection 

Go to the Insert > Audio > Record Audio option to record audio using a 

microphone. 

Now, you will see the Record Sound option pop up. Press the red Record button, 

and PowerPoint will start grabbing audio. When you are finished, press 

the Stop button (Black Square) to add your audio to PowerPoint. 

 

Figure 6.8 record button  



 

 

Press the record button to record audio inside your presentation and add it to the 

PowerPoint file. 

PowerPoint lets you make minor edits and adjustments to audio files without 

having to open another app. With the audio file selected, the most useful options 

are found on the Audio Tools > Playback menu. 

Here are some of the most useful options: 

 Trim Audio - Open this option to reduce your audio file to play only a 

selection of the original file. 

 Start - Change from On Click to automatically to play the audio without 

clicking the speaker icon. 

 
Figure 6.9 playback selection 

 

Using PowerPoint Audio Tools, Playback options. 

 

Video is a powerful multimedia type you can use. PowerPoint supports adding 

video from your computer or online. Let us look at how to insert and modify them:  

If you have a video clip on your computer, you can quickly drop it into your 

presentation by using the Insert menu. Go to Insert > Video > Video on My PC to 

browse to your video file. 



 

 

 

Figure 7.0 adding a clip on PowerPoint 

 

After browsing to the video and inserting it, you will see it placed on your slide with 

the playback controls. 

Once the video is on your slide, you can drag the corners to resize it and control 

how much of the slide it covers. 

PowerPoint has good support for most of the major video file types, like MP4, 

QuickTime, and Windows Media files.  

Finding an inspiring or insightful YouTube video can help make drive your point to 

reach an audience. Instead of finding a workaround to download and convert a 

YouTube video, PowerPoint can link to and insert them directly. 

To add a YouTube (or other online) video, go to Insert > Video > Online Video to 

launch the menu. 



 

 

 

Figure 7.1 inserting a video online 

To add an online video, choose Insert > Video > Online Video to get started. 

Now, PowerPoint will show a new window to search for or add an online video. If 

you want to add a YouTube video, you can drop in the URL for a video, or search 

directly inside this box for a relevant clip. 

Other sites might give you embed codes on their site. On sites like Vimeo or TED, 

try out the Embed code and dropping the HTML into the bottom box. 

 

Figure 7.2 search box selection 

Search for videos using the box or drop in a URL for a YouTube video of your 

choice. 



 

 

Adding a YouTube video is a great way to include a video without increasing your 

PowerPoint file size. Instead of embedding the video inside the file, the link will 

play a YouTube video, right inside the presentation.  

Just as PowerPoint has built-in tools to adjust images, the Playback Options are 

great to adjust how a video plays inside the presentation. 

With the selected video, click on the “Video Tools > Playback” option on the 

ribbon, to access key settings to control the video. 

 

Figure 7.3 Video Tools > Playback selection 

With a video selected, you can use the Video Tools > Playback options to edit your 

video inside of PowerPoint. 

Here are several key options to try out to change how the video plays: 

 Start - Change this option from "On Click" to "Automatically" to start 

playing the video as soon as the slide appears. 

 Play Full Screen - With this option turned on, playing the video will cut to a 

full screen mode with the rest of the slide hidden. 

 Trim Video - Open this option to select which parts of the video to reduce 

the video to the parts you want to show. 

 

Before sharing a presentation, you will want to make sure it does not include any 

information you want to keep private. You may also want to discourage others 

from editing your file. Fortunately, PowerPoint includes several tools to help 

finalize and protect your presentation.  

 

 

 



 

 

Whenever you create or edit a presentation, certain personal information may be 

added to the file automatically. You can use the Document Inspector to remove 

this type of information before sharing a presentation with others. 

Because some changes may be permanent, it is a good idea to use Save As to 

create a backup copy of your presentation before using the Document Inspector. 

To use the Document Inspector: 

1. Click the File tab to go to backstage view. 
2. From the Info pane, click Check for Issues, and then select Inspect 

Document from the drop-down menu. 

 

Figure 7.4 document inspector selection 

3. The Document Inspector will appear. Check or uncheck the boxes, 
depending on the content you want to review, then click Inspect. In our 
example, we'll use the default selections. 



 

 

 

Figure 7.5 document inspector 

4. The inspection results will show an exclamation mark for any categories 
where it found potentially sensitive data, and it will also have a Remove All 
button for each of these categories. Click Remove All to remove the data. 

 

Figure 7.6 document inspection result 

5. When you are done, click Close. 



 

 

 

Figure 7.7 close selection 

By default, anyone with access to your presentation will be able to open, copy, and 

edit its content unless you protect it. There are several ways to protect a 

presentation, depending on your needs. 

To protect your document: 

1. Click the File tab to go to backstage view. 
2. From the Info pane, click the Protect Presentation command. 
3. In the drop-down menu, choose the option that best suits your needs. In 

our example, we'll select Mark as Final. Marking your presentation as final 
is a good way to discourage others from editing the file, while the other 
options give you even more control if needed. 



 

 

 

Figure 7.8 info tab selection 

4. A dialog box will appear prompting you to save. Click OK. 

 

Figure 7.9 OK tab selection 

5. Another dialog box will appear. Click OK.  

 

Figure 8.0 dialog box 



 

 

6. The presentation will be marked as final. 

 

Figure 8.1 final presentation 

Marking a presentation as final will not prevent someone from editing it. If you 

want to prevent people from editing it, you can use the Restrict Access option 

instead. 

 

1. Open an existing PowerPoint presentation. 

2. Use the Document Inspector to check the presentation. Remove all 

personal information from the presentation. 

3. Protect the presentation by marking it as final. 

Discuss 

Write down the steps you used to do the activity. Compare your steps with your 

partner. Do they contrast? Share the steps with the rest of your class. 

Demonstrate: 

 How you can use Document Inspector and what is the role of it in 

PowerPoint presentation? 

 How you can protect your presentation in MS PowerPoint? 

 How you can insert online video in PowerPoint 2013? 

 How you can customize slide layout? 

 How you can record a slide show? 



 

 

 

Visual Basic is a computer programming language that you studied in S3. It allows 

the creation of user-defined functions and the automation of specific computer 

processes and calculations. Users do not have to buy a copy of Visual Basic 

professional because Visual Basic for Applications is a standard feature of Microsoft 

Office products. Visual Basic for Applications (VBA) allows users additional 

customization beyond what is normally available in Microsoft Office products, such 

as Excel, Access, Word and PowerPoint. 

Visual Basic for Applications an event-driven programming language that is now 

predominantly used with Microsoft office applications such as MS Excel, MS-Word, 

and MS-Access.  

VBA helps to build customized applications and solutions to enhance the 

capabilities of those applications. The advantage of this facility is that you need not 

have visual basic installed on our PC; however, installing Office will implicitly help in 

achieving the purpose. 

You can use VBA in all office versions, right from MS-Office 97 to MS-Office 2013 

and also with any of the latest versions available. Among VBA, Excel VBA is the 

most popular. The advantage of using VBA is that you can build very powerful tools 

in MS Excel using linear programming.  

In VBA, users type commands into an editing module to create a macro. Macros 

allow users to automatically generate customized charts, reports and perform 

other data processing functions. Macros automate tasks and merge program 

functions that enable developers to build custom solutions using Visual Basic. 

Visual Basic for Applications requires code to run within a host application such as 

Excel because it cannot run as a standalone application. 

In the finance industry, VBA for Excel is frequently used to create and maintain 

complex financial spreadsheet models. Visual Basic for Applications for Excel is also 

used to create trading, pricing and risk management models, forecast sales and 

earnings and generate financial ratios. 

It is user intuitive, which allows users with little or no computer programming 

knowledge to learn VBA. It is an event-driven programming language specifically 

designed to customize applications that contain the Visual Basic for Applications 

application-programming interface (API). It is used to control the functionality of 

Microsoft Excel and any other Microsoft Office application. 



 

 

It can be used to keep lists of customers’ names or other data, create invoices and 

forms, develop charts, analyze scientific data and for budgeting and forecasting. It 

can be used to control several features of a host application such as Excel, including 

manipulating user interface features, such as toolbars and menus and working with 

dialog boxes or customized user forms. 

In addition to Microsoft, numerous companies have used VBA to add the 

programming capabilities to their own applications. Visual Basic for Applications is 

also implemented in applications published by other companies including AutoCAD, 

ArcGIS, CATIA, CorelDraw and SolidWorks. VBA enables an application, such as 

Excel, to run a program internally and provide a customized version of Excel for a 

specific purpose, such as how long it takes to earn 1 million in an investment 

portfolio based on a specific interest rate and the number of years until retirement. 

MS-Excel provides only basic inbuilt functions which might not be sufficient to 

perform complex calculations. Under such circumstances, VBA becomes the most 

obvious solution. 

For example, it is very hard to calculate the monthly repayment of a loan using 

Excel's built-in formulas. Rather, it is easy to program a VBA for such a calculation.  

How to use a VBA macro to remove line breaks from the current worksheet. 

1. Open your workbook in Excel. 
2. Press Alt+F11 to open Visual Basic Editor (VBE). 

https://www.ablebits.com/office-addins-blog/2013/12/03/remove-carriage-returns-excel/#vba-macro-delete-carriage-returns


 

 

 

Figure 8.2 Visual basic editor 

3. Right-click on your workbook name in the "Project-VBAProject" pane (at the 
top left corner of the editor window) and select Insert -> Module from the 
context menu. 

 

Figure 8.3 module selection  

4. Copy the VBA code (from a web-page etc.) and paste it to the right pane of 
the VBA editor ("Module1" window). 



 

 

 

Figure 8.4 module 1 window selection 

Tip: How to speed up macro execution. 

If the code of your VBA macro does not contain the following lines in the 

beginning:  

Application.ScreenUpdating = False 

Application. Calculation = xlCalculationManual 

5. Then add the following lines to get your macro to work faster (see the 
screenshots above):  

 To the very beginning of the code, after all code lines that start with 
Dim (if there are no "Dim" lines, then add them right after the Sub 
line): 
Application.ScreenUpdating = False 

Application.Calculation = xlCalculationManual 
 To the very of the code, before End Sub: 

Application.ScreenUpdating = True 

Application.Calculation = xlCalculationAutomatic  

These lines, as their names suggest, turn off screen refresh and recalculating the 

workbook's formulas before running the macro. 

After the code is executed, everything is turned back on. As a result, the 

performance is increased from 10% to 500% (the macro works 5 times faster if it 

continuously manipulates the cells' contents). 

Save your workbook as "Excel macro-enabled workbook". Press Crl+S, then click 

the "No" button in the "The following features cannot be saved in macro-free 

workbook" warning dialog. 



 

 

 

Figure 8.5 no selection 

The "Save as" dialog will open. Choose "Excel macro-enabled workbook" from the 

"Save as type" drop-down list and click the Save button. 

 

 

Figure 8.6 save as type dialog selection 

Press Alt+Q to close the Editor window and switch back to your workbook. 

A macro is a piece of computer code that is written using the Visual Basic for 

Applications (VBA) programming language. 

When you want to run the VBA code that you added as described in the section 

above: press Alt+F8 to open the "Macro" dialog. 

Then select the wanted macro from the "Macro Name" list and click the "Run" 

button. 



 

 

 

Figure 8.7 run selection dialogue 

The words macro and function are often used interchangeably to refer to 

procedures written in Visual Basic for Applications (VBA).  However, it is important 

to distinguish between SUB procedures, or macros, and FUNCTION procedures.   

The difference between the two is how they are invoked, and their ability to 

change the working environment. 

Macros are pre-processed which means that all the macros would be processed 

before your program compiles. However, functions are not preprocessed but 

compiled.  

See the following example of Macro: 

#include<stdio.h> 

#define NUMBER 10 

int main() 

{ 

     printf("%d", NUMBER); 

     return 0; 

} 



 

 

Output: 

10 

 

See the following example of Function: 

#include<stdio.h> 

int number() 

{ 

    return 10; 

} 

int main() 

{ 

    printf("%d", number()); 

    return 0; 

} 

Output: 

10 

  

Macros are no longer recommended as they cause following issues. There is a 

better way in modern compilers that is inline functions and const variable. Below 

are disadvantages of macros: 

a) There is no type checking 

b) Difficult to debug as they cause simple replacement. 

c) Macro does not have namespace, so a macro in one section of code can 

affect other section.  

Although Excel provides hundreds of Built-In Spreadsheet Functions, you can also 

create your own functions by writing Excel macros to perform specific tasks. 

You can even add your own macros to the Excel’s function menu, so that they are 

available to you in the same way as Excel's built-in functions. 

 

 

 

 



 

 

 

1. What is advanced formatting? 

2. How are templates created in MS word? 

3. How are templates created in MS PowerPoint? 

4. How do you customize computer applications for automation and 

efficiency? 

5. List the steps for creating a table of content in MS word 

6. In order to move a picture freely around a MS word document, which 

setting must be changed? 

7. What’s the reason for adding a section break in a MS word document? 

8. What are functions and macros and how are they used? 

9. In order to prevent someone from editing a shared Word document, which 

option should the author use? 

10. List the steps for creating a multimedia content in a MS PowerPoint   



 

 

 

 

SPECIFIC LEARNING OUTCOMES 

By the end of this unit you should; 

 Know the principles of and the techniques of design, management and 

updating of a website using basic website development software tools. 

 Use appropriate basic software for website design 

 Carryout website management and updating 

Key inquiry questions 

1. What is a website? 

2. What basic software can be used for website design? 

3. How websites are designed, hosted, managed and updated? 

4. What is website content? 

5. What are the security issues to be considered when setting up a website 

and why are they important? 

 

 

 

 

 

 

 

 

 

 

 

 

  



 

 

Web design is the visual aesthetics and page layout of a website. It goes hand-in-

hand with web development in the creation of a static website or dynamic web 

application. 

The design is the first thing people notice when they arrive on a website, and if it is 

not good enough, they will leave. You do not want to create a site that frustrates 

people. 

The website design process starts with a visual concept, which can be sketched by 

hand or with software like Photoshop. Then, you use HTML and CSS to build the 

website. HTML and CSS are the codes for writing web pages. HTML handles the 

basic structure the page, while CSS handles the style and appearance. Website 

design includes concepts like responsive design, aesthetics, usability and 

accessibility when building your site. 

Responsive design is a popular technique for making websites look good and 

function well on additional devices, like phones and tablets. It does this by setting 

different CSS rules for different browser widths. 

 

Work in pairs 

1. What is the software used to design, manage and update a website? 

2. What are the main differences between a blog and a corporate website? 

3. What are the principles of website management and updating? 

Group Discussion 

Discuss and share your answers in groups, what are the similarities of the answers? 

 

 

HTML is the standard markup language for creating Web pages. It describes the 

structure of Web pages using markup. 



 

 

HTML elements are the building blocks of HTML pages these elements are 

represented by tags <>. These tags label pieces of content such as "heading", 

"paragraph", "table" etc. 

Browsers do not display the HTML tags, but use them to render the content of the 

page. 

HTML tags are element names surrounded by angle brackets: 

<tagname>content goes here...</tagname> 

 HTML tags normally come in pairs like <p> and </p> 
 The first tag in a pair is the start tag, the second tag is the end tag 
 The end tag is written like the start tag, but with a forward slash inserted 

before the tag name  

The start tag is also called the opening tag, and the end tag the closing tag. 

<!DOCTYPE html> 

<html> 

<head> 

<title>Page Title</title> 

</head> 

<body> 

<h1>My First Heading</h1> 

<p>My first paragraph. </p> 

</body> 

</html>  

 

 The <!DOCTYPE html> declaration defines this document to be HTML5. 

 The <html> element is the root element of an HTML page. 

 The <head> element contains Meta information about the document. 

 The <title> element specifies a title for the document. 

 The <body> element contains the visible page content. 

 The <h1> element defines a large heading. 

 The <p> element defines a paragraph. 

4. Copy the html code and copy them in a notepad program in your computer. 

5. Save as: 

 file name: name.html 



 

 

 Save as type: all files 

6. Open with your browser. 

 

To make text bold, websites use the <strong> tag.  

Closing tags are <strong>very</strong> important. 

 

Here’s the result: 

Closing tags are very important. 

The word ‘very’ has been bolded because it is surrounded by the <strong> tag. 

Italics are much the same, but the <em> tag is used. Example: 

In HTML, <strong>bold</strong> is for <strong>making text stand 

out</strong>, and <em>italics</em> are for <em>emphasis</em>. 

 

Result: 

In HTML, bold is for making text stand out, and italics are for emphasis. 

 

 

 

 



 

 

Below is a visualization of an HTML page structure: 

 

Figure 8.8 HTML page structure 

Only the content inside the <body> section (the white area above) is displayed in a 

browser. 

 

CSS describes how HTML elements should be displayed. 

 

 



 

 

1. Copy the html code and copy them in a notepad program in your computer. 

2. Save as: 

• file name: name.html 

• Save as type: all files 

3. Open with your browser. 

 

Figure 8.9 browser interface 

A CSS rule-set consists of a selector and a declaration block: 

 

The selector points to the HTML element you want to style. 

The declaration block contains one or more declarations separated by semicolons. 

Each declaration includes a CSS property name and a value, separated by a colon. A 

CSS declaration always ends with a semicolon, and declaration blocks are 

surrounded by curly braces. 

In the following example all <p> elements will be center-aligned, with a red text 

color: 



 

 

 

 

Result; 

 

HTML supports 140 standard color names. Colors are specified using predefined 

color names, or RGB, HEX, HSL, RGBA, HSLA values. 

In HTML, a color can be specified by using a color name: 

 

 



 

 

 

 

 

 



 

 

Result; 

 

 

 

Result; 

 

 

 



 

 

Result: 

 

 

Work in pairs 

1 Create a webpage in html. Include colors, a menu bar in the header, paragraph 

and contacts at the footer.  

Discuss 

Share and discuss your results with other groups. Which groups website is more 

appealing? 

 

 

Adobe Dreamweaver is an all-in-one visual development tool that allows you to 

create, publish, and manage websites and mobile content. Adobe Dreamweaver 

has powerful techniques for creating professional, dynamic websites using real-

world, hands-on exercises. 



 

 

 

Figure 9.0 Adobe Dreamweaver cs6 interface. 

Adobe Dreamweaver is an all-in-one visual development tool that allows you to 

create, publish, and manage websites and mobile content. Dreamweaver provides 

a visual workflow with advanced site management capabilities and support for 

technologies such as: 

• JavaScript 

• PHP 

• XML 

Adobe Dreamweaver makes it easy for anyone to build a professional looking web 

page, and it reduces the time it takes to create and maintain web sites. 

Adobe Dreamweaver has powerful techniques for creating professional, dynamic 

websites using real-world, hands-on exercises. 

1. Planning a Website: Think about your potential audience and what you want 

them to do when they come to your website. Then think about what the site 

needs to do to help them achieve it. 

2. Creating a Sitemap: Create a visual Site Map of your website and decide how 

the content will be grouped. Also determine what functionality the pages will 

have and what kind of navigation system you will be using. Consider usability as 

well as design, and get your client to approve a Site Map before starting the 

design work. 



 

 

2. Developing Website Visuals: Designing and building a successful website 

always starts with solid, thoughtful planning. Consider all the elements that'll 

appear on a page before beginning site construction. 

Many web designers start by drawing thumbnails with pencil and paper. Think of 

thumbnails as a graphical shopping list of the pages you will need to create for the 

website. Thumbnails can also help you work out the basic website navigation 

structure. Draw lines between the thumbnails showing how your navigation will 

connect them. 

 

Thumbnails list the pages that need to be built and how they are connected to each 

other. 

Most sites are divided into levels. Typically, the first level includes all the pages in 

your main navigation menu, the ones a visitor can reach directly from the home 

page. The second level includes pages you can reach only through specific actions 

or from specific locations, say from a shopping cart or product detail page. 

Once you have figured out what your site needs in terms of pages, products, and 

services, you can then turn to what those pages will look like. Make a list of 

components you want on each page, such as headers and footers, navigation, and 

areas for the main content and the sidebars (if any). Put aside any items that will 

not be needed on every page. What other factors do you need to consider? 



 

 

1. Header (include banner logo) 

2. Footer (copyright information) 

3. Horizontal navigation(for internal reference, i.e. home, about us, contact 

us) 

4. Vertical navigation(links to product and services) 

5. Main content(one column, with a chance of two or more) 

Do you have a company logo, business identity, graphic imagery, or color scheme 

you want to accent? Do you have publications, brochures, or current advertising 

campaigns you want to emulate? It helps to gather them all in one place so you can 

see everything all at once on a desk or conference table. 

Once you have created your checklist of the components that you will need on 

each page, sketch out several rough layouts that work for these components. Most 

designers settle on one basic page design that is a compromise between flexibility 

and sizzle. Some site designs may naturally lean toward using more than one basic 

layout. But resist the urge to design each page separately. Minimizing the number 

of page designs may sound like a major limitation, but it is key to producing a 

professional-looking site. It is the reason why some professionals, like doctors and 

airline pilots, wear uniforms. Using a consistent page design, or template, lends a 

sense of professionalism and gives confidence to your visitor. 

 

While you figure out what your pages will look like, you will have to address the 

size and placement of the basic components. Where you put a component can 

drastically affect its impact and usefulness. In print, designers know that the upper-

left corner of a layout is considered one of the “power positions,” a place where 

you want to locate important aspects of a design, such as a logo or title. This is 

because in western culture people read from left to right, top to bottom. The 

second power position is the lower-right corner because this is the last thing your 

eyes will see when you are finished reading. 



 

 

Unfortunately, in web design this theory does not work so well because of one 

simple reason: You can never be certain how the user is seeing your design. Are 

they on a 20-inch flat panel or a 2-inch cell phone? 

In most instances, the only thing you can be certain of is that the user can see the 

upper-left corner of any page. Do you want to waste this position by slapping the 

company logo here? Or, make the site more useful by slipping in a navigation 

menu? This is one of the key predicaments of the web designer. Do you go for 

design sizzle, workable utility, or something in between? 

1. If you were designing a website for a school what content you would include in 

the; 

 Header  

 Main content 

 Horizontal navigation 

 Vertical navigation 

 Footer 

Discuss in groups 

Write a brief content on each section of the website and compare and contrast 

with your group members. Present the best content to the class.   

 

Wire framing is an important step in website design process because it allows you 

to define the information hierarchy of your design, making it easier for you to plan 

the layout according to how you want your user to process the information.  



 

 

 

Wire framing allows the designer to plan the layout and interaction of an interface 

without being distracted by colors and typeface choices. 

Wire framing is a fast way to work out the structure of each page in the site. A 

wireframe is like a thumbnail, but bigger, that sketches out each page and fills in 

more details about the components, such as actual link names and main headings. 

This step helps to catch or anticipate problems before you smack into them when 

working in the code. 



 

 

 

The wireframe for the final design should identify the components and feature 

markup for content, color, and dimensions. Once the basic concepts are worked 

out, many designers take an extra step and create a full-size mockup or “proof of 

concept” using a program like Adobe Fireworks, Photoshop, or even Illustrator. It is 

a handy thing to do because you will find that some clients just are not comfortable 

giving an approval based only on pencil sketches.  

The advantage here is that all these programs allow you to export the results to 

full-size images (JPEG, GIF, or PNG) that can be viewed in a browser. Such mockups 

are as good as seeing the real thing but may take only a fraction of the time to 

produce. 

 



 

 

In some cases, creating a mockup in Photoshop, Fireworks, or Illustrator can save 

hours of tedious coding to receive a needed approval. 

Design process can be started in Fireworks, where a fully functional mockup can be 

created (with menus, links, and hotspots) that can then be exported to a CSS-based 

HTML layout and then edited in Dreamweaver. 

As you go through the following section it would be useful to work on the 

computer and gain practical experience of building a website.

2. Create a Local Root Folder 

Create a local root folder and put it on a desktop. This is where all the files and 

subfolders will be saved as we work on Dreamweaver CS6. Though Dreamweaver 

can do this for us using the default folder and location, it is better to create your 

own folder which easy to find and manage. 

3. Creating a New Site 

 On the Menu Bar click on Site and a drop down menu will appear. You 

can also do this on the Application Bar since there is specific button 

there for Site as well. 

 

 Choose New Site to bring up the Site Setup Dialog Box. 



 

 

 By default, the name of the site is Unnamed Site 2. Change the Site 

Name by typing in the name of the site that we will be working on. 

 By default, Local Site Folder is assigned to 

C:\User\Username\Documents\Unnamed Site 2. Browse the root folder 

by clicking the open folder icon. 

 Double-click the root folder, and then click Select. 

 

 Click Save once the Site Name and Local Site are all setup. 

 



 

 

After saving, a Files Panel with Assets Panel will pop-up. The Files Panel keeps track 

of all the files are going to be used in website. You can either close it or click the 

little double arrow to collapse it into icons. When it collapses into icons, it becomes 

a smaller panel which allows you to move it anywhere you want to keep it out of 

the way. 

Here are some things to avoid when naming files or folders for Web use:  

 Spaces (For example, my file.html is an invalid filename.) have you ever 

noticed the characters %20 in a URL? This results when the browser or server 

converts a space in a URL into a code that is more universally understood by 

computers.  

 periods that do not immediately precede a file extension (myfile.html is 

correct; my.file.html is not) 

 any character that is not a letter, number, dash, or an underscore (while 

underscores are legal, they are often unnecessary, creating barriers in linking 

and typing the URL) 

 Capitalization (Technically, capitalization is legal, but like underscores, capital 

letters may not be recognized properly and create unnecessary barriers in 

linking and typing the URL.) 

Put some content in the website using the File Menu from the Welcome Screen. 

1. On the Welcome Screen, go to the File Menu and click on New. This brings up 

the New Document Dialog which contains many options for creating New 

Documents in Dreamweaver. 

2. Select Blank Page on the first column and then pick a Page Type. 



 

 

 

Figure 9.1 creating a new document using a blank page856 

There are many Page Type options for the new document for the website in 

Dreamweaver CS6. The first option for Page Type is HTML. Keeping HTML selected, 

there are numerous page layouts to choose from. 

1. Click on HTML in the second column of the New Document Dialog. 

2. In the third column named Layout, select one of the layouts for your page. 

3. When done selecting Page Type and Layout, click on Create. 

 



 

 

 

Figure 9.2 choosing a blank HTML page 

 

  

All of Dreamweaver's tools are contained in various windows and panels. Panels 

are divided and organized into a series of Panel Groups based on the functions they 

contain. You can control which of these panel groups is visible by selecting and 

deselecting them in the Window menu. The checked items are currently showing: 

 

 



 

 

 

Figure 9.3 panels window 

The Insert panel (shown in the nest page) allows you to insert various "objects" 

(such as tables, forms, and images) into your page. You can format or set attributes 

for these objects as you insert them. 



 

 

 

Figure 9.4 insert panel window 

The Dreamweaver CS6 Insert panel has several groupings of related objects: 

 Common (shown above) - for most commonly used objects. 
 Layout - for divs, spry objects, and table elements. 

 Forms - for form elements. 
 Data - for spry data objects and other dynamic elements, such as record 

sets. 
 Spry - for building spry pages. 

 JQuery Mobile - for building jQuery Mobile pages. 
 InContext Editing - for creating InContext editable regions within 

pages. 
 Text - for text-centric tags (e.g., headings, lists, inline tags, etc.). 
 Favorites - can be customized to display just the options that you use 

most often. 



 

 

The Dreamweaver CC Insert panel has several groupings of related objects: 

 Common (shown above) - for most commonly used objects. 
 Structure - for divs, and lists. 

 Media - for media elements. 
 Form - for form components. 

 JQuery Mobile - for building jQuery Mobile pages. 
 JQuery UI- for building jQuery User Interface. 
 Templates - for creating template regions within pages. 
 Favorites - can be customized to display just the options that you use 

most often. 

The Properties Inspector (shown below), which appears at the bottom of 
Dreamweaver in the Designer workspace, is context-based, meaning it will change 
depending on what type of object is selected. For example, if text is selected, text 
properties will be visible; if an image is selected, image properties will be visible, 
and so on:  

 

Figure 9.5 properties inspector window 

Every page element can be customized via the Properties Inspector. For 

example, text can have a specified font, size, and style. Images can have a specified 

height, width, and source. To customize an element, select it within the 

Document Window (the main editing area) and make alterations via the 

Properties Inspector. 

The Properties Inspector is split into two sections: HTML and CSS. Click 

on the HTML or CSS icons on the left side of the inspector to switch between the 

two. 

Note CS6: When the CSS icon is selected and you attempt to change properties of 

text, Dreamweaver will automatically open the New CSS Rule dialog prompting 

you to create a new CSS rule. These rules will all be covered later in the course. 



 

 

Note CC: When the CSS icon is selected and you attempt to change properties of 

text, Dreamweaver will automatically create a new Inline CSS rule. These rules will 

all be covered later in the course. 

The Files panel (shown below) keeps track of all of the files and folders within 

your site. It can also be used to browse the files on a computer or network just as 

 

Figure 9.6 files panel 

 

 Code View - Edit and view your web page's HTML. 

 Split View - Divides both the Design and Code view to allow you to see the 

HTML coding as you lay out your website. One pane displays your HTML 

code while the other pane shows you the page as it may appear in the web 

browser. This view allows a designer mobility between the coding and the 

layout. It is also best used when you want to debug or troubleshoot a 

webpage. 

 Design View - Edit your web page the way it may appear in your web 

browser without needing to manually enter code.  

The rest of the Document Toolbar includes many other important features: 

 



 

 

 Live - Preview what your page will look like live on the Web without leaving 

Dreamweaver. Click the Live View button to toggle these views.  

 You cannot edit your page in Design view while Live is active; you must click 

the button again to leave live view. 

 Multiscreen Preview - Test what your page will look like at different 

breakpoints. 

 Preview/Debug in Browser - See your page on any browser you have 

installed on your computer. Always test your webpages in multiple 

browsers! 

 Validate Current Document (W3C) - Test for validation within 

Dreamweaver. 

 Visual Aids - Display or hide element borders in Design view. 

 

 

Figure 9.7 Dreamweaver workspace 

Dreamweaver's workspace consists of the Document Window and a collection of 

panels, each containing a series of options for formatting, managing and inserting 

content. 

 Document Window: the browser-approximate main workspace where web 

pages are created and edited using the panels and toolbars. 

 Files Panel: view and manage the files in your Dreamweaver site. 



 

 

 Insert Panel: create and insert new elements (anything that is manually 

inserted onto your Document Window).  

 The buttons found in this toolbar are organized into categories. Select 

categories using the dropdown menu above the icons. 

 Properties Panel: edit the attributes and formatting of any page element 

that is currently selected on your web page. Take note that your Properties 

Panel buttons and options may change to reflect any attributes of any 

selected element, such as when an image is selected. 

 Quick Tag Editor: Displays how a selected element is nested and lets you 

change code while still in Design view. 

 Multiscreen Preview: Test your page to see how it will render at three 

common device breakpoints. 

 

 Title Field - Enter a title for your page, no longer than 65characters. This 

text is visible to visitors in the browser and in search engine results.  

In the Document toolbar's Title text field, type in a brief but descriptive title for 

your page. Press Enter (Windows) or Return (Mac). The page title appears at 

the top of the browser when the page is being viewed, in search engines when 

your site is listed among search results, and is the name used by browsers when 

the page is bookmarked. Titles should be less than 65 characters (including 

spaces) to prevent getting cut off when listed in search engine results. The most 

important/unique part of the title should come first. 

Follow the steps above and create a web page of a school.  

Discuss 

Design a mockup illustration of the website. Share with your group which is the 

most unique illustration? What are the similarities and differences of these 

illustrations?  

 

 



 

 

 

1. In this exercise, you will create and view a simple web page. 

a) Create a new HTML page using any of the methods described above. 

b) Place the cursor on the page and type "Hello world!” 

c) Save the page (File > Save) as hello-world.html in your Class 

Files/Dreamweaver/Exercises folder. 

d) When you are done, make a screenshot of your page using a snipping tool. 

e) Write the steps you used to create the page.  

 

2. In this exercise, you will modify your Preview in Browser settings and 

preview a page in different browsers. 
a) Open ClassFiles/Dreamweaver/Exercises/hello-world.html in 

Dreamweaver if it is not already open. 

b) Preview the page in Live View. 
c) Preview the page in one or more browsers. 
d) Make some small modification to the page and preview again. 

  



 

 

 

The paragraph is the default format for a block of text. Just like in a word 

processor, when you press Enter at the end of one paragraph, Dreamweaver begins 

a new paragraph. 

To illustrate let us add a paragraph to ClassFiles/Dreamweaver/Exercises/hello-

world.html: 

1. Open ClassFiles/Dreamweaver/Exercises/hello-world.html in Dreamweaver if it 

is not already open. 

2. Place your cursor at the end of the first line of text and press Enter (Return on a 

Mac). 

3. Type the following: 

 The text 'Hello world!' is very often used in the first exercise of programming 

classes. 

4. Save your page. 

5. Preview the page in your browser (File > Preview in Browser). It should appear 

as follows: 

 

HTML supports six levels of headings. Heading 1 is the most important and Heading 

6 is the least important. Like paragraphs, headings are block-level elements, 

meaning that they affect the whole line of text (or multiple lines if the heading is 

long enough to wrap).  



 

 

There are several ways to add headings in Dreamweaver, but the most common is 

to use the Properties Inspector. To illustrate: 

1. Open ClassFiles/Dreamweaver/Exercises/hello-world.html in Dreamweaver if 

it is not already open.  

2. Place your cursor anywhere in the first paragraph (i.e, the "Hello world!" 

paragraph).  

3. Select "Heading 1" for the Format in the Properties Inspector: 

 

4. Save your page. 

5. Preview the page in your browser (File > Preview in Browser). It should appear 

as follows: 

 

You can also add headings from the Format menu or using shortcut keys: 



 

 

 

To add a new paragraph after a heading, place the cursor at the end of the heading 

text and press Enter. 

Block quotes are used to designate quoted blocks of text. In Dreamweaver, block 

quotes are added by clicking on the Block quote icon in the Properties 

Inspector:  

 

To remove the block quote, click the Remove Block quote icon () to the left of the 

Block quote icon. 

To illustrate let us add a block quote to ClassFiles/Dreamweaver/Exercises/hello-

world.html: 

1. Open ClassFiles/Dreamweaver/Exercises/hello-world.html in Dreamweaver if it 

is not already open. 

2. At the end of the first paragraph under the heading, type "According to 

Wikipedia:" 

3. Press Enter to add a new paragraph. 

4. Open ClassFiles/Dreamweaver/Exercises/hello-world-blockquote.txt and copy 

all the text. 

5. Switch back to hello-world.html and paste the text into the new paragraph you 

added. 



 

 

6. In the Properties Inspector click on the Block quote icon ( ). 

7. Save your page. 

8. Preview the page in your browser (File > Preview in Browser). It 

should appear as follows:  

 

Block quotes should only be used to indicate that the content is taken from 

another source. The proper way to indent paragraphs for formatting purposes is to 

use CSS. 

 

 

Dreamweaver makes adding links easy. Simply highlight the text that you want to 

turn into a link and enter the link URL into the Link field in the Properties 

Inspector. 

Activity: adding links to a text 



 

 

To illustrate let us add a link to ClassFiles/Dreamweaver/Exercises/hello-

world.html: 

1. Open ClassFiles/Dreamweaver/Exercises/hello-world.html in Dreamweaver if it 
is not already open. 

2. Highlight the text "Wikipedia". 
3. In the Link field in the Properties Inspector, enter 

"http://en.wikipedia.org/wiki/Hello_world_program":  

 

4. Save your page. 

5. Preview the page in your browser (File > Preview in Browser). The page should 

look like this: 

 

6. Notice that when you hover over the link, the cursor turns to a pointer and 

Firefox shows the URL to which the link points. 

7. Click the "Wikipedia" link. It should take you to Wikipedia's page entitled "Hello 

world program." 

Sometimes it is desirable for a link to open in a new tab or window, so that the 

page with the link does not get replaced. Dreamweaver provides a Target field in 

the Properties Inspector for this purpose. This Target field remains 



 

 

inactive until the Link field is filled in, at which point it gives you the options 

shown in the screen shot below:  

 

The _parent, _self, and _top values apply to framesets and should not be used 

(unless you are designing with framesets, which you probably should not be). 

The _blank and new values will both direct the linked page to open in a new 

window. The difference is that all links that target _blank will spawn new windows, 

whereas a link targeting new will open a new window and name it "new". As long 

as that window remains open, all future links targeting new will open in that same 

window. In fact, new is an arbitrary target name. You will get the same behavior 

with any target name other than the four reserved names: _blank, _parent, _self, 

and _top. 

Be careful not to overuse targeting new windows. A best practice in web design is 

to give users what they expect and users generally expect links to replace the 

current page. They also know that they can get back to the original page using the 

browser's Back button. However, when creating a link that opens in a new window, 

the user will not be able to use the Back button in that new window to get back to 

your page. Reserve the open a new window for links that take the user away from 

your site, so any links to other sites work well in a new window as your site will still 

be available when they close that window. 

Email links are used to open an email client to start a new email message. The 

value you enter in the Link field must begin with mailto: and ends with an email 

address. For example: mailto:paul@gmail.com 

You can also add an email link by selecting Insert > Email Link, and then 

filling out the resulting dialog:  



 

 

 

Figure 9.8 Email link 

If you select the text you want to turn into an email link before selecting Insert > 

Email Link then that text will show up in the Email Link dialog. Otherwise, you must 

type in the text in the dialog box and Dreamweaver will add it to the page at the 

point where the cursor is. 

1. Create the following new pages and save them in 

ClassFiles/Dreamweaver/Exercises. Add titles and level-one headings to each 

page: 

 Races as Races.html 

 Calculator as Calculator.html 

 Running Log as RunningLog.html 

 My Account as MyAccount.html 

 Log out as Logout.html 

2. Open ClassFiles/Dreamweaver/Exercises/index.html in Dreamweaver if it is not 

already open. 

    Add the following links: 

 Home: index.html 

 Races: Races.html 

 Resources: Resources.html 

 Calculator: Calculator.html 

 Running Log: RunningLog.html 

 My Account: MyAccount.html 

 Log out: Logout.html 

 the most up-to-date information on running races: Races.html 

 the best resources for runners: Resources.html 



 

 

 

3.  Save your page and open it in the browser. 

4.  Test your links. Do they work? 

Anchors are named locations to which a link can point. Anchors make it possible to 

link to a specific location on a page. 

Follow these steps to add an anchor in Dreamweaver CS6 using the pre HTML5 

way: 

1. Place the cursor where you want to add the anchor. 

2. Select Named Anchor from the Insert menu or the Common Insert 
panel. 

3. In the resulting dialog, enter a name for your anchor (no spaces allowed):  

To illustrate let us add an anchor to the top of 

ClassFiles/Dreamweaver/Exercises/Anchors.html so that we can add a "Back to 

Top" link at the bottom of the page: 

1. Open ClassFiles/Dreamweaver/Exercises/Anchors.html in Dreamweaver.  

2. With the cursor at the very beginning of the page (before the "Anchors" 

heading), select Insert > Named Anchor: 

 
3. In the Named Anchor dialog, enter "Top":  

4. You should now see an anchor icon ( ) in front of the "Anchors" heading. 

If you do not, you may need to change your preferences by selecting Edit > 



 

 

Preferences and then selecting the "Invisible Elements" category and 

checking Named anchors 

 

Figure 9.9 invisible elements selection 

You are now ready to create a link to your new anchor. To do so: 

 

1. Scroll down to the bottom of your Anchors.html page and highlight "Back to 

top." 

2. In the Properties Inspector, enter "#top" in the Link field. The pound sign or 

hash mark (#) at the beginning of the link value is important. It tells the browser 

to search for an anchor on the page. 

3. Save your page and open it in the browser. 

4. Scroll to the bottom of the page and test the link. Does it bring you back to the 

top? 

To link to anchors on remote sites, simply include the whole URL followed by a 

pound sign and the anchor. For example: http://www.example 

com/index.html#anchorname. Or in the case of a default page: 

http://www.example com/#anchor name. 

 



 

 

 

 

Add content to your web page. 

1. Create a new HTML page and save it as index.html in your Exercises folder. 
2. Add content so that your web page will look like this in the browser:  

 

3. Save your page and open it in the browser. Does it look like the screen shot 
above?  

 

 

 

1. Highlight the text that will become a link. 
2. Click down on the Point to File icon in the Properties 

Inspector. 
3. Drag the mouse over to the Files panel and point to the file. 



 

 

 

1. Highlight the text that will become a link. 
2. Click on the folder icon (if you hover over the folder icon, it will show Browse 

for files) in the Properties Inspector: 

 

3. In the Select File dialog that appears, click on the Site Root button to 

quickly navigate to your website root: 



 

 

 

Alternatively, you can type the URL into the URL field. 

4. Navigate to the file and click OK. 

1. Highlight the text that will become a link. 

2. In the Files panel click down on the file to which you want to link. 

3. Click down on the Point to File icon in the Properties 

Inspector. 
4. Drag the mouse over to the Properties Inspector and point to the 

Link field. Although the "no-drop" cursor might show up, Dreamweaver 
allows you to drop the file path into the field.  

 

 

To add an image place the cursor where you want the image to appear and do one 

of the following: 



 

 

 

 Select Insert > Image:  
 Select Images > Image from the Common Insert panel:  

 

You will then be presented with the Select Image Source dialog, which 

allows you to navigate to your image: 



 

 

 

As with links, this dialog gives you the option of jumping right to your website root 

by clicking on the Site Root button. 

Rather than browsing to the image in the Select Image Source dialog, you 

can drag it from the Files panel to the location on your page where you want the 

image to appear. 

After selecting the image, the Image Tag Accessibility Attributes dialog will appear:  

 

Figure 10.0 Accessibility attributes dialog 



 

 

Screen readers will use the Alternate text value when announcing the 

presence of the image. You should either write descriptive text or select "<empty>" 

from the dropdown. Here are some guidelines: 

1. If the only purpose of the image is to provide a design impact, you should 
select "<empty>". 

2. If the image contains instructive text (e.g., "Enter Store" or "Go"), you 
should write that text as the value. 

The long description is used with images that tell a story (e.g., graphs and charts). 

The value for the Long description, if included, should be a URL pointing to a 

page that provides text telling the same story as the image. 

Watch as your instructor adds the world.gif image from the Images folder to 

ClassFiles/Dreamweaver/Solutions/hello-world.html and makes it a link to the 

Hello World Wikipedia page. 

You can use the Properties Inspector to modify the properties of the 

image:  

 

Figure 10.1 image properties selection 

1. You can change the source, link URL, and alternate text using the Src, 
Link and Alt fields. 

2. W and H stand for width and height. 
3. When you insert an image, Dreamweaver automatically sets the width and 

height to the actual dimensions of the image (in pixels). In most cases, you 
should not change this setting. If one of the values is different from the 
actual dimension, the value becomes bold and a Reset icon appears:  

 

http://en.wikipedia.org/wiki/Hello_world_program


 

 

4. Click that icon to reset the image dimensions. 

1. Select the image. 
2. Add the link in the same way you would with text selected. 

Some browsers will place a blue border around a linked image to indicate that the 

image is a link.  

To add a table to your page, place the cursor where you want the table to appear 

and do one of the following: 

 

 Select Insert > Table:  

Select Table from the Common Insert panel:  

 



 

 

You will then be presented with the Table dialog: 

 

In the Table dialog, you enter: 

 Rows and Columns. The number of rows and columns you want for your 
initial table. Rows and columns can be added to and removed from the 
table later. 

 Table width: The width of the table in pixels or percent. Percent applies 
to the containing area. For example, if you nest a table with a width set at 
50% within a table cell of another table, the nested table will take up 50% of 
the cell. 

 Border thickness: The border width in pixels. The border will be 
applied to all cells of the table in a grid format. Enter "0" if you do not want 
a border. 

 Cell padding: The amount of space in pixels that will separate the cell 
content from the cell border. 

 Cell spacing: The amount of space in pixels that will separate each cell 
from each other cell. 

 Header: Whether you want a header row, header column, or both. 



 

 

 Caption: The caption you want to appear above the table. This is 
unformatted by default, but can be formatted with CSS. 

 Summary: The text used by screen readers to describe the table. 

To illustrate, let us add a table to a page: 

1. Open ClassFiles/Dreamweaver/Exercises/table.html in Dreamweaver. 
2. Place the cursor in the empty paragraph after the "Employees" heading. 
3. Select Insert > Table. 
4. Fill out the Table dialog as shown below: 

 

Click OK. Your page should look like this: 

 



 

 

In Design View, when the table is selected, Dreamweaver provides table menus 
(the green lines, arrows, and text above the table) to help you understand and 
modify the table. These will not appear on the page when viewed in the browser. 

5. Click the Live button to see what the page will look like in the browser:  

 

6. Now fill out the table as shown below. You can use Tab, Shift + Tab, and the 
arrow keys to navigate between cells. 

 

7. Save the page and leave it open. 

Notice that the data in the first row is bold and centered. That is not because it is a 

heading row. You can change any cell to or from a heading row in the Properties 

Inspector by checking or unchecking the Header field: 

 

 

 

Certain common documents, such as Microsoft Word (.doc), Excel (.xls) and 

PowerPoint (.ppt), as well as Acrobat (.pdf), can be added to your site as 



 

 

downloadable files. The user must have the appropriate editing or viewing 

software to make use of such documents.  

1. All files used in Web sites, including downloadable documents, should avoid 
spaces and special characters in the file name 

2. If working with your own document, examine the file on your computer's 
desktop  

 Re-name the file to remove any spaces or special characters 
 You can use dashes (-) or underscores (_) instead of spaces 
 The file must have the correct extension, e.g. ".doc" for Word 

documents or ".pdf" for Acrobat documents 

1. Still on your computer's desktop, find and open your site's local folder 
2. Look for a folder at the site's root named "files" or "documents" or perhaps 

"secure"; if you do not find one of these, create a new folder named 
"documents" 

3. Move your sample document into this folder 

1. Switch to Dreamweaver; you may want to right/ctrl-click on the list of files 
and select "Refresh Local Files" to update the list. 

2. Find an open the "documents" folder by double-clicking on it. 
3. Select the document within and click the Put button in the files panel 
4. Open the page you want to link from, e.g. my project/index.html or 

root/my_page.html. 
5. Create a new link to the file the same way you would if linking to a page, i.e. 

using the Browse button or the Point to File button. Because the user must 
have appropriate software, it is customary to warn them in the link text that 
the link is to a downloadable file, e.g. "Application Form (PDF)" . 

6. Save, Put and switch to the browser to reload and validate by clicking the 
link. 

 

https://med.stanford.edu/irt-resources/webauthor/training/dreamweaver/setup.html#step2
https://med.stanford.edu/irt-resources/webauthor/training/dreamweaver/body_links.html#step1
https://med.stanford.edu/irt-resources/webauthor/training/dreamweaver/downloadables.html


 

 

In groups 

Develop a website for Rumbek secondary school. Include name, logo, and levels of 

classes, subject and teacher names and pictures. Include picture gallery of activities 

such as sports, cultural event and field visits. Include a pdf document for school 

performance in the national exam. 

Group Discussion 

Which group has the best design and why? What are the main recommendations 

for creating a good website?  

 

 

 

When you point your browser to a website (e.g., www.google.com), the browser 

fetches a page from a web server somewhere on the internet. That web server is 

simply a computer with some special software on it for serving web pages and 

associated files (e.g., images). The server can deliver pages to many different 

clients (browsers) at the same time as shown below: 

 

Figure 10.2 a server image 



 

 

As a web developer, you may be responsible for putting your pages onto the web 

server. Different organizations handle this in different ways, but one common way 

is via File Transfer Protocol (FTP).  

The file transfer function available in Dreamweaver does more than simply move 

files to and from a server.  

The function actually serves as a file management system where the user is able to 

upload and download files, synchronize files on the server and local computer, and 

much more. 

1. Click Site on the Menu bar. A drop down list will appear as illustrated on the 

right. 

 

Select New Site.  The Set Up panel will appear. It will resemble the illustration 

below. 



 

 

 

Enter the name of your Web site in the Site Name space.  This is the name by which 

you will recognize your site. It can be any name you wish, but if you work on 

several sites you will want to be sure that it is a name that cannot be confused with 

another site. 

You must enter the Local Site Folder information. This is the site’s root folder on 

your computer. You can click the Folder button to navigation to the root folder 

location. 

Find the root folder then click Save. You will return to the Site Setup panel.  It will 

now resemble the illustration below. 



 

 

 

Click Servers in the left column of the Set Up panel.  The panel will change to look 

like the illustration below. 

 

This is where you will specify the server that hosts your Web site. Your Web master 

or the company that provides your hosting service will supply the information that 

you need.  

It will include a username, path to the server, password, and, perhaps, other 

details. 



 

 

If you do not have that information on hand, you can still work on your site. The 

details about the root folder location and name that you set up in the previous 

panel are enough for Dreamweaver to start to track your project. However, until 

you complete the FTP setup you will not be able to transfer the files to the hosting 

server. 

Click the Add New Server + button. The Server Information panel appears as shown 

below. Click the Basic tab at the top of the panel. 

 

Enter the Server Name. In some instances a server may have a special name. This is 

not always the case. Your Web master or host provider will tell you what this 

special name might be, if it is needed. Otherwise the server name can be just about 

anything you wish.  

You may find it easiest if the server name matches the Web site name. 

Make sure that FTP is selected in the Connect Using drop down box. 

 



 

 

 

Your Web master or host provider will advise you if a special version of FTP is 

required, such as SFTP for secure file transfer. Local/Network is used if you connect 

without using FTP over a network.  

Using this illustration below as a guide, enter the following information: 

 



 

 

FTP Address: This is the “place” on the Internet where your Web site resides. This 

address specifies not only the location, but also the method by which you get 

there.  In simple terms, this example indicates that you get to “mywebsite.com” via 

FTP (File Transfer Protocol). In some instances the FTP address will actually start 

with “www” as in www.mywebsite.com. Your Web master or host company will tell 

you which to use. It is also possible that you may not be given a typical URL for 

connection purposes. In that case your Web master or host company might provide 

an IP address, which is a string of numbers such as 128.123.45.86. Sometimes host 

companies require specialized access pathways that incorporate their domain 

names. In such a case your FTP address could be something similar to 

www.amazinghostcompany.com/x429/mywebsite/. 

Username: Type in the username that your Web master or host company gives 

you. 

Password: Type in your password. 

Root Directory: If your Web master or host company specifies a special directory 

(also called a “folder”), enter it here. The most common name for such a directory 

is public_html. This is common industry practice. Any file in this directory is 

“officially” part of the Web site. If it is not in this directory it is not a Web site file.   

Not all host servers require specifying a root directory, so be sure to check with 

your Web master or hosting provider.  It is very important to make sure you files go 

to the right place!  

Click the Test button.  If Dreamweaver connects to the server properly you will get 

a success message.  If there is a problem you will receive a message that indicates 

possible solutions. 

The More Options selector will expand the panel to show additional FTP choices. 

They will include using Passive FTP, IPV6, and more. If you receive an error message 

when you test, trying some of these options may help.   

 

http://www.amazinghostcompany.com/x429/mywebsite/


 

 

If you continue to receive error messages, check your FTP Address, Username, and 

Password choices. These are the most common sources of connection problems. If 

the connection errors continue, contact your Web master of Host Company for 

assistance.  

Once connection is successful, click the Save button once or twice until the Site 

Setup Panel disappears. You are now ready to transfer files. 

On your main Dreamweaver screen you will find the Files panel in the lower right 

corner. It is circled in the illustration below. If it is not displayed, click Windows on 

the Menu bar and then click the Files option. 

 

The Files panel has a series of buttons across the top.  

 



 

 

Connection: The Connection button activates the FTP connection between your 

computer and the host server. It does not necessarily start a file transfer, it only 

makes the connection.  

Refresh: The Refresh button updates the list of files to reflect changes you have 

made.  

Get: The Get button is the download button. It “gets” the files from the server and 

brings them to your computer.  

Put: The Put button is the upload button. It “puts” the files from your computer 

onto the host server.  

Sync: The Sync button starts a process of synchronizing the files between the host 

server and your computer. Be very careful using this button. It has several options, 

once you have clicked it, and it is important to choose the right option. This sync 

feature makes managing a Web site easier than many people expect.  

Expand: The Expand button opens a new window that has two panes. The right 

side pane will show all of your Web site files on your computer, the left side pane 

will show all of the Web site files on the host server.  

Once you have set up your connection to your host server, uploading and 

downloading (or “Put” and “Get” as Dreamweaver likes to say) is very easy.  

The illustration on the right shows the Files panel. The same steps can be used in 

expanded view, but what you see on the screen will be a little different. 

 



 

 

Make sure that the Local View is selected in the View drop down selector on the 

top right corner. This shows the files that are on your computer.   

 

Highlight the file you wish to upload. You may highlight more than one file. You can 

also select entire folders. 

Click the Put button. 

 

The Dependent Files panel will appear. It is illustrated below: 

 

The question in the panel is asking if you want to upload the dependent files 

associated with main file, or file, that you have elected to upload. But what are 

dependent files?  

To understand the concept of dependent files it easiest to image a Web page that 

you wish to upload. That page will consist of the HTML file of the page itself, and 

associated files that give the page its look and feel. These include image files. 

If you click Yes in the Dependent Files panel the HTML file and the images will be 

uploaded. It is possible that additional files may also be uploaded. Clicking Yes does 

not guarantee that CSS, video, sound, or other files will be uploaded as they are 

probably considered “linked” but not dependent.  

If you click No only the file, or files, that you have selected will be uploaded.  

Clicking Cancel will stop the download action.  



 

 

Your decision to click Yes or No can be based on many considerations. Among them 

are:  

 Clicking yes will almost for sure upload all the files necessary to display your 

Web page.  

 Clicking yes will probably lengthen the time it takes to accomplish the 

upload because of the number of files.  

 Clicking No will result in a quicker upload  

 Clicking No means you could miss important files  

Once you click Yes or No the upload (or Put) process will start. If everything goes 

perfectly a panel will appear that displays the progress of the Put operation.  You 

can monitor the Put progress from this panel. 

If there are problems or questions that Dreamweaver encounters other panels may 

be displayed. One of the most common is the panel shown below: 

 

This panel indicates that Dreamweaver has discovered that the file on the server is 

believed to be newer than the file you are putting.  If you click yes, the file you 

selected for upload will overwrite the file on the server. If you click yes to all, this 

action will occur whenever this conflict is detected.  

Clicking No will prevent the Put file from overwriting the file on the server, and 

clicking No to all does the same for all conflicts.  

The problem that is often encountered is that the new file selected for upload is 

not really older than the file on the server.  The conflict can be a reflection 

incorrect dating of the files on the hosting server. If you are confident that you are 

REALLY NOT uploading an old file it is perfectly OK to click yes or yes to all.  

Downloading, or getting, a file is just as easy as Putting a file. But, you have one 

important decision to make regarding the selection of the file.  



 

 

If you have the Local View in the Files panel selected, you can simply highlight that 

file and click the Get button.   

If you are not sure about which file you need to Get, change the view to Remote 

Server. All the files on the host server will be displayed. Highlight the file and then 

click the Get button.  

In either instance, when you Get a file you will be asked about overwriting your 

local file, the one on your computer, and whether or not you want to download the 

dependent files.  Make your selections as appropriate to the situation.  

The Synchronize function in Dreamweaver is very powerful and a good example of 

how Dreamweaver goes beyond having a simple FTP feature and becomes a total 

site management tool.  

 

When you click the Sync button Dreamweaver will ask a series of questions.  

Make your selection of the options carefully as they will affect what happens next.  

The Synchronize Files panel is shown below. 

 

You will be given the options to:  

 Synchronize the entire Web site or only the files you select.  

 Put (upload) the newest files to the host server; Get (download) the newest 

files to your computer; or Put and Get the newest files to and from the 

server and your computer.  



 

 

Click the Preview button. Dreamweaver will analyze the files on your computer and 

the server and list the ones that need to be uploaded or downloaded. You will be 

given the option to take action as desired.  

Once you have synced the server and your local files on your computer you have 

duplicate file structures on each machine. This means that site management, 

maintenance, updating, and editing are easy.   

 

In pairs 

What are the security issues to be considered when settings up a website? Are they 

important? 

Discuss 

List and explain security issues to be considered in website management and their 

importance. Discuss your answers with your partner. What are they key points? 

Prepare a presentation for your answer with examples and present to the class. 

 

 

 

1. What three questions should you ask before starting any web design project? 

2. What is the purpose of using thumbnails and wireframes? 

3. What is the advantage of inserting the banner as a background image? 

4. How can you insert the cursor before or after an element without using Code 

view? 

5. How does the Code Navigator assist in designing your website layout? 

6. Which element or idea would you use to improve website usability? 

7. Based on best practices, which three site elements should remain consistent 

throughout when designing a website?  

8. Which three items might appear on the project plan when discussing an 

upcoming website with a design team? 

  



 

 

1. ACID - The acronym standing for the properties maintained by standard 

database management systems, standing for Atomicity, Consistency, 

Isolation, and Durability. 

2. Application Server - A server that processes application-specific database 

operations made from application client programs. The DBMS is in-process 

with the application code for very fast internal access. 

3. Atomicity - The property of a transaction that guarantees that either all or 

none of the changes made by the transaction are written to the database. 

4. B-tree - An indexing method in which the values of the columns used in the 

index are efficiently maintained in sorted order that also provides fast 

access (three or four additional disk accesses) to an individual index entry.  

5. Cache - The computer memory that is set aside to contain a portion of the 

database data that has most recently been accessed by the database 

application program. A cache is used to minimize the amount of physical 

disk I/O performed by the DBMS. 

6. Cascade - A foreign key attribute that automatically migrates the changes 

made to a referenced (i.e., primary key) table to the entire referencing 

foreign key) table rows. 

7. Catalog - A source for the computer-readable form of a database's data 

definition meta-data. Sometimes called the system catalog or just syscat. 

8. Client - A client-side process, containing proxy functions, connecting to a 

server process that contains the actual database functions. 

9. Client/Server - A server is a program that runs on a computer that directly 

manages the database. A client is a separate program (or process) that 

communicates with the database server through some kind of Remote 

Procedure Call (RPC) in order to perform application-specific database 

operations. 

10. Cloud - used to describe an execution model for computing systems where 

functions and data are invoked by a name that refers to a remote system 

whose location is irrelevant (hence the concept of it being "out there 

somewhere." like a cloud). Cloud-based systems allow thin-client interfaces 

to access this functionality through the internet, and frequently with Wi-Fi, 

reducing the power requirements of the client computers. 

11. Column - A single unit of named data that has a particular data type (e.g., 

number, text, or date). Columns only exist in tables. 



 

 

12. Commit - The action that causes all of the changes made by a particular 

transaction to be reliably written to the database files and made visible to 

other users. 

13. Concurrency - The property in which two or more computing processes are 

executing at the same time. 

14. DLL - Dynamic Link Library. A library of related functions that are not loaded 

into memory until they are called by the application program. All RDM APIs 

are contained in DLLs on those operating systems that support them (e.g., 

MS-Windows). These are sometimes called shared libraries on some 

systems. 

15. DML - Database Manipulation Language. In SQL, such statements as 

UPDATE, INSERT and DELETE are considered DML. 

16. Documentation - All product-related materials, specifications, technical 

manuals, user manuals, flow diagrams, file descriptions, or other written 

information either included with products or otherwise.  

17. Domain - An alternate name for a base data type that is defined using the 

RDM SQL create domain statement. 

18. Durability - The property of a transaction in which the DBMS guarantees 

that all committed transactions will survive any kind of system failure. 

19. Dynamic DDL - The ability to change the definition of a database (its 

schema) after data has been stored in the database without having to take 

the database off-line or restructure its files. 

20. Encryption - The encoding of data so that it cannot be understood by a 

human reader. This usually requires the use of an encryption key. A 

common encryption algorithm is called AES, which uses encryption keys of 

128, 192 or 256 bits.  

21. End-User - An entity that licenses an Application for its own use from 

Licensee or its Additional Reseller. 

22. Enterprise resource planning (ERP):  is the integrated management of core 

business processes, often in real-time and mediated by software and 

technology. ERP is usually referred to as a category of business-

management software. Typically a suite of integrated applications—that an 

organization can use to collect, store, manage and interpret data from these 

many business activities.  

23. Foreign Key - One or more columns in a table intended to contain only 

values that match the related primary/unique key column(s) in the 

referenced table. Foreign and primary keys explicitly define the direct 

relationships between tables. Referential Integrity is maintained when 

every foreign key refers to one and only one existing primary key. 



 

 

24. Grouped Lock Request - A single operation that requests locks on more 

than one table or rows at a time. Either all or none of the requested locks 

will be granted. Issuing a grouped lock request at the beginning of a 

transaction that includes all of the tables/rows that can potentially be 

accessed by the transaction guarantees that a deadlock will not occur. 

25. Hierarchical Model - A special case of a network model database in which 

each record type can participate only as the member of one set. 

26. Hot Spot - In a database, a hot spot is a single shared row of a table that is 

used and updated so often that it creates a performance bottleneck on the 

system. 

27. I/O - Input/output. For a DBMS, this is normally a disk drive, used to create 

database durability. 

28. Index - A separate structure that allows fast access to a table's rows based 

on the data values of the columns used in the index. RDM supports two 

indexing types: hash and b-tree. A SQL key (not foreign key) is implemented 

using an index. 

29. In-memory - A feature in which the DBMS keeps the entire contents of a 

database or table available in computer memory at all times while the 

database is opened. Frequently, in-memory databases are volatile, meaning 

that they have little or no durability if the computer malfunctions. Durability 

issues are frequently prioritized below performance, which increases 

substantially with memory as the storage media. 

30. In-process - When referring to a DBMS, it is in-process when the DBMS 

code resides in the process space of the application program that is using it. 

If the process is single threaded, then this is a single-user usage of the 

database(s). A process may have multiple threads with individual 

connections to a shared database, making it a multi-user database. In-

process uses Local Procedure Calls (LPC) vs Remote Procedure Calls (RPC) to 

a database server in a separate process. 

31. Inner Join - A join between two tables where only the rows with matching 

foreign and primary key values are returned. 

32. IP Address - A numerical identification tag assigned to a computing device 

in a network. Originally, internet IP addresses consisted of 32 bits of data, 

displayed as a set of four 3-digit numbers separated by periods (e.g., 

113.12.214.2). The number of available IP addresses is running out and a 

new standard, called IPv6, with 128 bits, will expand the address space for 

the foreseeable future. 

33. ISO - International Organization for Standardization. Along with the IEC, the 

ISO controls the SQL standard (ISO/IEC 9075) and many others as well. 



 

 

34. Java - A multi-platform, object-oriented programming language, similar to 

C++, which is freely available to any and all software developers. It is 

particularly important in the development of internet/web and mobile 

applications. 

35. JDBC - Java Database Connectivity API. JDBC provides a standard database 

access and manipulations API for Java programs. RDM supports JDBC. 

36. Join - An operation in which the rows of one table are related to the rows of 

another through common column values. 

37. Key - A column or columns on which an index is constructed to allow rapid 

and/or sorted access to a table's row. 

38. LAN - A Local Area Network is used to interconnect the computers in a 

single geographic location. Contrasted to Wide Area Networks (WAN). 

Bandwidth (speed) is a primary difference between local and wide-area 

networking. 

39. Library - The container for a set of common software API functions. 

Frequently, a library is contained in a DLL or Shared Library. 

40. Locking - A method for safely protecting objects from being changed by two 

or more users (processes/threads) at the same time. A write (exclusive) lock 

allows access from only one user (process/thread) at a time. A read (shared) 

lock allows read-only access from multiple users (processes/threads). 

41. Meta-data - "Data about data." In a DBMS context, data stored in columns 

of a table have certain attributes, such as the type, length, description or 

other characteristics that allow the DBMS to process the data meaningfully, 

or allow the users to understand it better. 

42. Natural Join - A join formed between two tables where the values of 

identically named and defined columns are equal. 

43. Network Model - A database in which inter-record type relationships are 

organized using one-to-many sets. This differs from a Hierarchical Model in 

that it allows a record type to be a member of more than one set. Individual 

rows can be retrieved using API functions that allow an application to 

navigate through individual set instances. 

44. Network - An inter-connection of computers and computing devices, all of 

which can send and receive messages from one another. The world's largest 

network is the internet, in which billions of computers are connected. 

45. NoSQL - A classification of data storage systems that are not primarily 

designed to be relationally accessed through the common SQL language. 

NoSQL systems are characterized by dynamic creation and deletion of 

key/value pairs, and are structured to be highly scalable to multiple 

computers. 



 

 

46. Open Source Software (OSS) - Software that is released under a Software 

License that (1) permits each recipient of the software to copy and modify 

the software; (2) permits each recipient to distribute the software in 

modified or unmodified form; and (3) does not require recipients to pay a 

fee or royalty for the permission to copy, modify, or distribute the software. 

47. Outer Join - A join formed between two tables that in addition to including 

the rows from the two tables with matching join column values will also 

include the values from one table that do not have matching rows in the 

other. 

48. Page Size - The size in bytes of a database page. 

49. Page - The basic unit of database file input/output. Database files may be 

organized into a set of fixed-sized pages containing data associated with 

one or more record occurrences (table rows). 

50. PLC - Programmable Logic Controller. 

51. Port - A network portal through which two computing processes can 

communicate. Where one IP Address typically identifies a device, a Port on 

that device identifies one of multiple potential communication channels. 

52. Portable - Software that has been developed to be able to run on many 

different computer hardware and operating systems with little or no 

change. 

53. Primary Key - A column or group of columns in a given table that uniquely 

identify each row of the table. The primary key is used in conjunction with a 

foreign key in another (or even the same) table to relate the two tables 

together. For example, the primary key in an author table would match the 

foreign key in a book table in order to relate a particular author to that 

author's books. 

54. Process - An instance of the execution of a program on a single computer. A 

process can consist of one or more threads executing, more or less, 

concurrently. The private memory used by a process cannot be accessed by 

any other process. 

55. Protocol - A specific method in which messages are formulated, formatted, 

and passed between computers in a network. Internet messages are passed 

between computers using the TCP/IP protocol. 

56. Query - A complete SELECT statement that specifies 1) the columns and 

tables from which data is to be retrieved; 2) optionally, conditions that the 

data must satisfy; 3) optionally, computations that are to be performed on 

the retrieved column values; and 4) optionally, a desired ordering of the 

result set. 

57. Read-only Transaction - A Multi-Version Concurrency Control (MVCC) 

feature that allows database data to be read by one process without 



 

 

blocking another process's modification of that same data. Frequently 

referred to as a "snapshot." 

58. Record Type - A collection of closely related data fields—equivalent to an 

SQL table. Similar to a C struct, a record type is defined by a set of closely 

related data fields. 

59. Relational Model - A database in which inter-table relationships are 

organized primarily through common data columns, which define a one-to-

many relationship between a row of the primary key table and one or more 

rows of the matching foreign key table. Equi-joins relate tables that have 

matching primary/foreign key values, but other comparisons (relationships) 

may be defined. In addition to describing how the database tables are 

related, the relational model also defines how the related data can be 

accessed and manipulated. SQL is the most commonly used relational 

model database language. See Wikipedia 

60. Remote Procedure Call - A method of inter-process communication where 

a function residing within another process is called as though it is a local (in-

process) function. The method is implemented through a local proxy 

function and a remote stub function. Parameter values are marshaled into a 

block of data that can be transmitted from the proxy to the stub for 

remarshaling and calling the actual function. Return values are processed in 

the same way as input values. 

61. Restriction Factor - Each relational expression specified in the WHERE 

clause of a query has an associated restriction factor that is estimated by 

the SQL optimizer, which specifies the fraction (or percentage) of the table 

for which the expression will be true. For example, in the query select * 

from book where bookid = 'austen013px' the relational expression bookid = 

'austen013px' has a restriction factor equal to .003 (only one out of 3213px 

rows will satisfy this expression). 

62. Rollback - An operation, usually performed by the SQL ROLLBACK 

statement, that discards all of the changes made by all INSERT, UPDATE and 

DELETE statements that have been executed since the most recently started 

transaction (e.g., START TRANSACTION statement). 

63. Row - One set of related values for all of the columns declared in a given 

table. Also known as a record occurrence. 

64. Runtime - A portion of a DBMS that is included within the process space of 

an application program. 

65. Scalability - A software system is scalable when its performance and overall 

system throughput continues to improve as more computing resources are 

made available for its use. This usually comes in the form of the number of 



 

 

CPUs and cores available in the computer on which the software system is 

run. 

66. Scalar Function - Either a built-in SQL function or a user-defined function 

that returns a single value computed only from the values of any required 

arguments at the time the function is called. 

67. Schema - A representation of the structure of a database. It may be 

graphical or textual. Graphical representations typically involve the use of 

boxes that represent database tables and arrows that represent inter-table 

relationships. Textual schema representations utilize Database Definition 

Language (DDL) statements to describe a database design. 

68. Semaphore - A primitive computing operation that is used to synchronize 

shared access to data. Sometimes called a "mutex" meaning a "mutually 

exclusive section." Semaphores control concurrent access to data by 

restricting access to critical sections of code that manipulate that data. 

69. Server (Software) - A Seat that resides on a single Server machine and is 

capable of accepting connections from one or more Seats residing on Client 

machines. 

70. Set - A method used to implement the one-to-many relationship formed 

between two tables based on their foreign and primary key declarations. 

The term "set" comes from the CODASYL Network Model definition. A set 

may be employed in a relational database when an owner (primary key) 

table and a member (foreign key) table where all of the member table rows 

that are related to the same owner table row are connected together with a 

linked list. See Wikipedia 

71. SQL - The standardized and commonly accepted language used for defining, 

querying and manipulating a relational database. The etymology of "SQL" is 

unclear, possibly a progression from "QueL" (Query Language) to "SeQueL" 

to "SQL." However, some experts do not like the expansion "Structured 

Query Language" because its structure is inconsistent and a historical 

patchwork. See Wikipedia 

72. Stored Procedure - A named and optionally parameterized compiled set of 

SQL database access statements that can be executed as a unit through a 

call to the stored procedure. 

73. Synchronization - The implementation method (frequently using 

semaphores) by which concurrently executing multiple computer threads or 

processes can safely access and update shared data. 

74. Table - A collection of closely related columns. A table consists of rows each 

of which shares the same columns but vary in the column values. 

75. Thread - A single, sequential execution of a computer program or program 

segment. A program can consist of one or more concurrently executing 



 

 

threads. Where multiple threads access the same data, some kind of 

synchronization method needs to be employed to ensure that the data is 

accessed only by one thread at a time. 

76. Timeout - Occurs when a lock request has waited longer than the 

prescribed wait time for the request to be granted. 

77. Transaction Log - A sequential record of all of the database changes made 

by each transaction in the order they were issued. The transaction log is 

used to ensure that a database conforms to the ACID properties. 

Transaction logs are also used to mirror or replicate data to other 

databases. 

78. Transaction - A set of logically related database modifications that is written 

to the database as a unit. The database changes associated with a given 

transaction are guaranteed by the DBMS to be written completely to the 

database; in the event of a system failure, none are written. The state of the 

database both before and after a transaction will be consistent with its 

design. 

79. Update (of Product) - A Product that has been modified in a minor way, 

including but not limited to bug fixes, and has been furnished to Licensee 

under this Agreement. An Update is represented by a Product version 

number that increments to the right of the decimal point. 

80. User-defined Procedure - An application-specific function written in C and 

invocable through use of the SQL call statement. 

81. Virtual Table - An SQL table that is defined through a set of application-

specific C functions that conform to a particular interface specification, 

allowing a non-database data source (e.g., a device, etc.) to be accessed as 

if it were a conventional SQL table. 

82. WAN - A Wide Area Network, as contrasted to Local Area Networks (LAN), 

Normally WAN refers to the internet. Bandwidth (speed) is a primary 

difference between local and wide-area networking. 

83. Wi-Fi - The common name for standardized local-area wireless technology. 

84. XML - Extensible Markup Language. XML documents are much used in the 

internet's World Wide Web but are also used in many computing contexts 

in which data needs to be shared. 

 

 



 

 

1. Action Buttons - these are buttons that you create in a presentation that 

perform an action when you click them. You can have an action button start 

a video, give information, play a sound, or move to a hyperlink. 

2. Animation Effects - Animation effects are builds, movement, and other 

special effects that can be applied to objects and text to add interest and 

variety to a presentation. 

3. Animations - Animations are effects that allow you to reveal the points on a 

slide one by one. 

4. Attribute - a characteristic of a text or graphic object that can be altered, 

such as bold, italic, shadowed etc. 

5. Audience Handouts - Audience handouts are small, printed versions of your 

slides that can contain an area for notes. They are usually printed and 

distributed to the audience. 

6. AutoContent Wizard - The AutoContent Wizard guides you through a 

number of formatting selections that will help you develop a clear, 

professional style for your presentation. 

7. AutoCorrect - a feature that corrects commonly misspelled words 

automatically as they are typed. 

8. Bookmark - a method to mark locations within a document so that they can 

be easily returned to later. 

9. Branching Slides - Branching slides provides one way to make one 

presentation to suit different audiences. Branching allows you to have two 

or more slide shows within a single slide show where you can run each 

when appropriate. 

10. Common Tasks Toolbar - The Common Tasks toolbar appears as a floating 

toolbar on the PowerPoint screen. It consists of options that allow you to 

quickly access commonly used dialog boxes, and these options change 

depending on your current process. 

11. Data Source - a document that is combined with the main document in a 

mail merge operation 

12. Digital Signature - a secure electronic stamp of authentication on a 

document. 

13. Drawing Canvas - an area that contains drawing shapes and pictures. 

14. Elapsed Time - The elapsed time for the slides that have been rehearsed is 

displayed on the left side of the Rehearsal Timer. 

15. Embedded Object - an object that becomes part of the destination file and 

is no longer a part of the source file. 

16. Endnotes - notes or references that appear at the end of the document. 



 

 

17. Entry - an index listing. 

18. Floating Toolbar - A floating toolbar is any toolbar that appears as a box in 

the working screen area. Any toolbar can be made into a floating toolbar by 

simply clicking-and-dragging the toolbar to the working screen area. 

19. Footnotes - comments or references that appear at the end of each page. 

20. Formatting Toolbar - The Formatting toolbar is located beneath the 

Standard toolbar, and contains buttons that provide quick access to 

commonly used formatting tools and options for the application. 

21. Indent Markers - markers along the ruler that control how text wraps on 

the left or right side of a document. 

22. Index - a list of the topics, names and terms used in a document along with 

the corresponding page numbers. An index is usually found at or near the 

end of a document (also see Table of Contents) 

23. Landscape - a term used to describe page orientation, where the page is 

wider than it is tall. 

24. Legend - A legend is a box that contains entries and keys that help identify 

the data series in a chart. 

25. Linked Object - an object such as a graphic etc., which is included within a 

document in such a way that it is linked to the source file, so that whenever 

the source changes, the object automatically updates. 

26. Macro - A recorded series of commands, menu selections and key presses 

that automate repetitive tasks. 

27. Mail Merge - The process of combining a standard ‘form’ letter with a set of 

names and addresses to create many letters that appear to be individually 

written. 

28. Main Document - the standard ‘form’ letter used in a mail merge process. 

29. Manual Page Break - a page break inserted into a document by the author 

at a specific position rather than one created automatically when a page 

has no more room for text. 

30. Merge Field - a placeholder that indicates where Word inserts information 

from a data source during a mail merge 

31. Module - the location within a VBA project where a macro is stored. 

32. Office Clipboard - a storage area that allows the user to temporarily store 

snippets of information, and retrieve them later. 

33. Orphan - the first line of a paragraph printed by itself at the bottom of a 

page. 

34. Pack And Go - Pack And Go "wraps up" your presentations and all of its 

elements, along with the PowerPoint Viewer, into a Pack and Go executable 

file so you can load and view it on any machine. 



 

 

35. Presentation - A presentation is a collection of slides, handouts, speaker's 

notes, and an outline, all combined into a file that can be printed onto 

transparencies or projected from a computer. 

36. Soft Page Break - a page break that is automatically inserted into a 

document by Word when a there is too much text to fit on the current 

page. 

37. Spelling and grammar checker - a feature that attempts to check and 

correct errors in spelling and grammar that the writer may have missed. 

38. Style - a collection of formatting choices that can be applied throughout a 

document. 

39. Table of Contents - a list of the main headings and sub headings that 

indicate to the reader the contents of a document. 

40. Template - a document that stores formatting, text styles and document 

information that is then used as the basis for another document. 

41. Theme - a unified look in a document that incorporates heading and text 

styles. 

42. Thesaurus - a feature that looks up alternative words with the similar 

meanings. 

43. Thumbnail - A thumbnail is a small view of the current slide. It appears in 

several different PowerPoint screens, including Outline view. 

44. URL - abbreviation of Uniform Resource Locator, a unique address for 

finding documents on a computer or the internet 

45. Watermark - semi-transparent text or picture that is ‘behind’ the main text 

of the document.  

46. Web Layout View - a view showing how a document will appear when 

viewed as a web page. 

47. Widow Line - the last line of a paragraph that appears at the start of a page 

on its own. 

48. WordArt - a tool within Microsoft Office that allows you to manipulate text 

in a variety of different graphical ways. 

49. Word Processing - the process of creating, editing and printing a computer 

written text document. 

50. Word Wrap - the movement of text to the next line when typing goes 

beyond the right margin. 

51. Workgroup Template - a template available to other users over a network. 

52. XY (Scatter) Chart - XY (scatter) charts show the relationship between the 

numeric values in several series of data. 



 

 

1. AP div tag - Creates a container that has a specified, fixed position on a web 

page. 

2. Anchor - This is a link that lets the viewer jump to a specific place in a page. 

Making one involves 2 processes: creating the anchor, and creating the link 

to the author 

3. Alt Tag - This is the text that displays before the image loads on the page. 

Speech synthesizers can read these tags. 

4. Assets panel - This panel includes the media that you have in your website 

as we;; as colors, links, library items, and templates. You can drag items 

from your Assets panel directly onto your web page. 

5. Background color - The color that fills the entire page. Background image 

this can extend into padding area but not into the margin area 

6. Border - This is the edge around tables and images. If you set the border to 

0, it will be transparent. You want to do this if you use an image to create a 

link. 

7. CSS Style Sheet - Formatting attributes used to format Web pages to 

provide a consistent presentation for content across the site 

8. Cell - The intersection of a row and column in a table 

9. Cell padding - The space between the side of the cell and whatever you 

place inside the cell. 

10. Cell spacing - The pixels of blank space between cells. 

11. Code view - Displays the code generated for the web page 

12. Commands menu - All options pertain to working with your HTML code 

13. Content - The information presented to the user in a web page 

14. Contrast - The range of optical density and tone on a photographic negative 

or print 

15. Default Color - The color the browser uses to display links if no other color 

16. Event - Something a user does or something that happens inside the 

browser window usually has the prefix "on".  

17. Extensions - These are special behaviors that you can download and use 

with the Extension manager to enhance the functionality of Dreamweaver.  

18. External hyperlink - A hyperlink that displays a web page document from 

another website 

19. External Style Sheet - Used for numerous web pages that will make up a 

web site, requiring pages to have a consistent text file, linked to web pages 

20. File menu - The options here are opening, saving, and testing your 

Dreamweaver files 



 

 

21. File name - The name of the file that stores the web page document. You 

want to keep them short, no capital letters, lowercase and easy to 

remember. 

22. Files panel - Area of Dreamweaver workspace that displays files and folders 

associated with the active website 

23. Float - The property determines where an element is placed relative to the 

containing element. It can be used to attach a div to a specific side of the 

containing element 

24. FTP Protocol - Allows users to copy files between their local system and any 

system they can reach on the network 

25. Home Page - The main page or starting point of the website. Usually named 

INDEX 

26. Hotspot - A clickable area on an image that, when the user clicks it, links to 

a different location 

27. HTML - Hypertext Markup Language, the authoring language used to create 

documents on the World Wide Web. It is the code behind all web pages 

worldwide and lets any computer on the network interpret the file as a web 

page. 

28. Inline style - This type of CSS Style is best used to format only a single 

element or a single page in a site 

29. Internal Style Sheet - CSS that is part of the html file, Used for individual 

pages containing large amounts of text. The tag <style> is placed inside the 

<head> section of the HTML code. 

30. Local site folder - A folder on a hard drive, flash drive, or floppy disk that 

holds all the files and folders for a website, local site folder/root folder. A 

folder on a hard drive that holds all the files and folders for a website. 

31. Meta Tags - HTML codes that include information about the page, such as 

keywords and descriptions, and reside in the head section. 

32. Navigation - This is how people move around within your site: how they go 

from one page to another. It should be simple, consistent, and accessible to 

all intended users. 

33. Objects panel - You can use the panel to insert a variety of objects into your 

page.  

34. Panel - These are floating menus that help you make changes to your web 

page. You can decide whether or not you want them to show, move them 

around, an expand and collapse them 

35. Pixel - A unit of measurement related to screen resolution 

36. Relative path - A path that references web pages and media files within the 

same site Dreamweaver maps the pathway between your site in relation to 

the other files in your site. 



 

 

37. Rollover - This is when one image changes to another when the cursor rolls 

over the image. You can create Rollovers easily within Dreamweaver and 

the Objects panel 

38. Root Folder - The folder created during site definition for storing files and 

folders 

39. <span> - Is used to format inline content, such as a part of a sentence, 

without create a line break in the text 

40. Standard view - This is one of the ways that you can create your web pages. 

With standard view you have a blank page and you insert elements into the 

page and then determine the attributes or properties for those elements 

41. <Style> - A combination of formatting characteristics such as alignment, 

font, font size, font color, fills color, and borders that are applied 

simultaneously. 

42. Tabular Data - Data that is arranged in columns and rows separated by a 

delimiter that tells Dreamweaver where to break the data into table cells 

43. Template - In Dreamweaver, you can save a page as this and designate 

editable and non-editable regions of it. 

44. Toolbar - This is the bar at the top of your document window and it allows 

you to switch between working modes, add a title, refresh your page, 

upload files, modify your HTML, and check HTML reference help 

45. Target - When you create a link to will need to "______" where and how 

that link opens it within the current window. If you create a link external to 

your site you may want set it as _blank so that the link opens in a new 

window 

46. Title - This is the name of your page. It needs to be a name that identifies 

your page. Search engines pick up the words in the title. This is also what 

your page will be called when someone bookmarks it. 

47. Time Stamp - A date or time that changes automatically when a page is 

modified 

48. WC3 - It is the international governing body for the development of 

platform independent web standards and specifications 

49. Web-safe color - Not all browsers or platforms display color the same. For 

this reason, it is recommended that you stick with web-safe color when you 

design your pages. 

50. Web server - A computer dedicated to hosting websites; it is connected to 

the internet and configured with software to handle requests from 

browsers 

51. White Space - Any blank are on a page, regardless of the color 

52. Window menu - This menu gives you options to control the display of 

various types of information 



 

 

53. Workspace - Dreamweaver application interface, which contains windows, 

toolbars, and panel groups. 

54. XHTML - This is the next generation of HTML and is a hybrid between HTML 

and XML. XML was designed to describe data. HTML was designed to 

display data. 


